Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 27 Mar 2013 10:29:05 -0300
From:      Leonardo Santagostini <lsantagostini@gmail.com>
To:        freebsd-questions@freebsd.org
Subject:   Release 9.1 and 3G usb Modem
Message-ID:  <CADmnP4Nh27_KQBiMi-n7e7EzWzRSnVrZpBuLmTuH=6qvqZon0A@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello all.

I have a latitude e6400 with FreeBSD Release 9.1. And i can't get the USB
modem working.

I tried with umodem, u3g but no luck :(

-- Dmesg
root@:/root # dmesg
Copyright (c) 1992-2012 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 9.1-RELEASE #0 r243826: Tue Dec  4 06:55:39 UTC 2012
    root@obrian.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
CPU: Intel(R) Core(TM)2 Duo CPU     P8400  @ 2.26GHz (2261.05-MHz 686-class
CPU)
  Origin = "GenuineIntel"  Id = 0x1067a  Family = 6  Model = 17  Stepping =
10

Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>

Features2=0x408e3fd<SSE3,DTES64,MON,DS_CPL,VMX,SMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,XSAVE>
  AMD Features=0x20100000<NX,LM>
  AMD Features2=0x1<LAHF>
  TSC: P-state invariant, performance statistics
real memory  = 2147483648 (2048 MB)
avail memory = 1967104000 (1875 MB)
Event timer "LAPIC" quality 400
ACPI APIC Table: <DELL   M09    >
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
FreeBSD/SMP: 1 package(s) x 2 core(s)
 cpu0 (BSP): APIC ID:  0
 cpu1 (AP): APIC ID:  1
ioapic0: Changing APIC ID to 2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
kqemu version 0x00010400
kqemu: KQEMU installed, max_locked_mem=980872kB.
acpi0: <DELL M09    > on motherboard
Timecounter "HPET" frequency 14318180 Hz quality 950
Event timer "HPET" frequency 14318180 Hz quality 450
Event timer "HPET1" frequency 14318180 Hz quality 440
Event timer "HPET2" frequency 14318180 Hz quality 440
Event timer "HPET3" frequency 14318180 Hz quality 440
acpi0: reservation of 0, 9f000 (3) failed
acpi0: reservation of 100000, 78f4d400 (3) failed
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x71,0x72-0x77 irq 8 on acpi0
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 2 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
acpi_ec0: <Embedded Controller: GPE 0x11> port 0x930,0x934 on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0xef70-0xef77 mem
0xf6c00000-0xf6ffffff,0xe0000000-0xefffffff irq 16 at device 2.0 on pci0
agp0: <Intel GM45 SVGA controller> on vgapci0
agp0: aperture size is 256M, detected 32764k stolen memory
vgapci1: <VGA-compatible display> mem 0xf6b00000-0xf6bfffff at device 2.1
on pci0
pci0: <simple comms> at device 3.0 (no driver attached)
atapci0: <Intel ATA controller> port
0xef78-0xef7f,0xef68-0xef6b,0xef80-0xef87,0xef6c-0xef6f,0xef90-0xef9f irq
18 at device 3.2 on pci0
ata2: <ATA channel> at channel 0 on atapci0
ata3: <ATA channel> at channel 1 on atapci0
pci0: <simple comms, UART> at device 3.3 (no driver attached)
em0: <Intel(R) PRO/1000 Network Connection 7.3.2> port 0xefe0-0xefff mem
0xf6ae0000-0xf6afffff,0xf6adb000-0xf6adbfff irq 22 at device 25.0 on pci0
em0: Using an MSI interrupt
em0: Ethernet address: 00:1e:c9:25:e8:07
uhci0: <Intel 82801I (ICH9) USB controller> port 0x6f60-0x6f7f irq 20 at
device 26.0 on pci0
uhci0: LegSup = 0x2f00
usbus0 on uhci0
uhci1: <Intel 82801I (ICH9) USB controller> port 0x6f80-0x6f9f irq 21 at
device 26.1 on pci0
uhci1: LegSup = 0x2f00
usbus1 on uhci1
uhci2: <Intel 82801I (ICH9) USB controller> port 0x6fa0-0x6fbf irq 22 at
device 26.2 on pci0
uhci2: LegSup = 0x2f00
usbus2 on uhci2
ehci0: <Intel 82801I (ICH9) USB 2.0 controller> mem 0xfed1c400-0xfed1c7ff
irq 22 at device 26.7 on pci0
usbus3: EHCI version 1.0
usbus3 on ehci0
hdac0: <Intel 82801I HDA Controller> mem 0xf6adc000-0xf6adffff irq 21 at
device 27.0 on pci0
pcib1: <ACPI PCI-PCI bridge> at device 28.0 on pci0
pci11: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> at device 28.1 on pci0
pci12: <ACPI PCI bus> on pcib2
iwn0: <Intel Ultimate N WiFi Link 5300> mem 0xf69fe000-0xf69fffff irq 17 at
device 0.0 on pci12
pcib3: <ACPI PCI-PCI bridge> at device 28.2 on pci0
pci13: <ACPI PCI bus> on pcib3
uhci3: <Intel 82801I (ICH9) USB controller> port 0x6f00-0x6f1f irq 20 at
device 29.0 on pci0
uhci3: LegSup = 0x2f00
usbus4 on uhci3
uhci4: <Intel 82801I (ICH9) USB controller> port 0x6f20-0x6f3f irq 21 at
device 29.1 on pci0
uhci4: LegSup = 0x2f00
usbus5 on uhci4
uhci5: <Intel 82801I (ICH9) USB controller> port 0x6f40-0x6f5f irq 22 at
device 29.2 on pci0
uhci5: LegSup = 0x2f00
usbus6 on uhci5
ehci1: <Intel 82801I (ICH9) USB 2.0 controller> mem 0xfed1c000-0xfed1c3ff
irq 20 at device 29.7 on pci0
usbus7: EHCI version 1.0
usbus7 on ehci1
pcib4: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib4
cbb0: <RF5C476 PCI-CardBus Bridge> irq 19 at device 1.0 on pci3
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
fwohci0: <1394 Open Host Controller Interface> mem 0xf68ff800-0xf68fffff
irq 17 at device 1.1 on pci3
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 35:4f:c0:00:2e:29:4e:21
fwohci0: Phy 1394a available S400, 1 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 36:4f:c0:29:4e:21
fwe0: Ethernet address: 36:4f:c0:29:4e:21
fwip0: <IP over FireWire> on firewire0
fwip0: Firewire address: 35:4f:c0:00:2e:29:4e:21 @ 0xfffe00000000, S400,
maxrec 2048
dcons_crom0: <dcons configuration ROM> on firewire0
dcons_crom0: bus_addr 0x76db8000
fwohci0: Initiate bus reset
fwohci0: fwohci_intr_core: BUS reset
fwohci0: fwohci_intr_core: node_id=0x00000000, SelfID Count=1, CYCLEMASTER
mode
pci3: <base peripheral, SD host controller> at device 1.2 (no driver
attached)
pci3: <base peripheral> at device 1.3 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH9M SATA300 controller> port
0x6e70-0x6e77,0x6e78-0x6e7b,0x6e80-0x6e87,0x6e88-0x6e8b,0x6ea0-0x6eaf,0x6e90-0x6e9f
irq 19 at device 31.2 on pci0
ata4: <ATA channel> at channel 0 on atapci1
ata5: <ATA channel> at channel 1 on atapci1
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
atapci2: <Intel ICH9M SATA300 controller> port
0x6eb0-0x6eb7,0x6eb8-0x6ebb,0x6ec0-0x6ec7,0x6ec8-0x6ecb,0x6ee0-0x6eef,0xefa0-0xefaf
irq 19 at device 31.5 on pci0
ata6: <ATA channel> at channel 0 on atapci2
ata7: <ATA channel> at channel 1 on atapci2
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
acpi_acad0: <AC Adapter> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
battery1: <ACPI Control Method Battery> on acpi0
acpi_tz0: <Thermal Zone> port 0x100-0x107 on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64,0x62,0x66 irq 1 on
acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model GlidePoint, device ID 0
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcf7ff,0xcf800-0xcffff pnpid
ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ata0: <ATA channel> at port 0x1f0-0x1f7,0x3f6 irq 14 on isa0
ata1: <ATA channel> at port 0x170-0x177,0x376 irq 15 on isa0
ppc0: parallel port not found.
ctl: CAM Target Layer loaded
est0: <Enhanced SpeedStep Frequency Control> on cpu0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
p4tcc1: <CPU Frequency Thermal Control> on cpu1
Timecounters tick every 1.000 msec
firewire0: 1 nodes, maxhop <= 0 cable IRM irm(0)  (me)
firewire0: bus manager 0
hdacc0: <IDT 92HD71B7 HDA CODEC> at cad 0 on hdac0
hdaa0: <IDT 92HD71B7 Audio Function Group> at nid 1 on hdacc0
pcm0: <IDT 92HD71B7 (Analog 2.0+HP/2.0)> at nid 13,10 and 11,14 on hdaa0
pcm1: <IDT 92HD71B7 (Analog)> at nid 15 and 24 on hdaa0
hdacc1: <Conexant (0x2c06) HDA CODEC> at cad 1 on hdac0
unknown: <Conexant (0x2c06) HDA CODEC Modem Function Group> at nid 2 on
hdacc1 (no driver attached)
hdacc2: <Intel Cantiga HDA CODEC> at cad 2 on hdac0
hdaa1: <Intel Cantiga Audio Function Group> at nid 1 on hdacc2
pcm2: <Intel Cantiga (HDMI 8ch)> at nid 3 on hdaa1
usbus0: 12Mbps Full Speed USB v1.0
usbus1: 12Mbps Full Speed USB v1.0
usbus2: 12Mbps Full Speed USB v1.0
usbus3: 480Mbps High Speed USB v2.0
usbus4: 12Mbps Full Speed USB v1.0
usbus5: 12Mbps Full Speed USB v1.0
usbus6: 12Mbps Full Speed USB v1.0
usbus7: 480Mbps High Speed USB v2.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
ugen1.1: <Intel> at usbus1
uhub1: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus1
ugen2.1: <Intel> at usbus2
uhub2: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus2
ugen3.1: <Intel> at usbus3
uhub3: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus3
ugen4.1: <Intel> at usbus4
uhub4: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus4
ugen5.1: <Intel> at usbus5
uhub5: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus5
ugen6.1: <Intel> at usbus6
uhub6: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus6
ugen7.1: <Intel> at usbus7
uhub7: <Intel EHCI root HUB, class 9/0, rev 2.00/1.00, addr 1> on usbus7
uhub0: 2 ports with 2 removable, self powered
uhub1: 2 ports with 2 removable, self powered
uhub2: 2 ports with 2 removable, self powered
uhub4: 2 ports with 2 removable, self powered
uhub5: 2 ports with 2 removable, self powered
uhub6: 2 ports with 2 removable, self powered
uhub3: 6 ports with 6 removable, self powered
uhub7: 6 ports with 6 removable, self powered
ada0 at ata4 bus 0 scbus2 target 0 lun 0
ada0: <Hitachi HTS722012K9A300 DCCOCA1H> ATA-8 SATA 2.x device
ada0: 300.000MB/s transfers (SATA 2.x, UDMA5, PIO 8192bytes)
ada0: 114473MB (234441648 512 byte sectors: 16H 63S/T 16383C)
ada0: Previously was known as ad8
cd0 at ata5 bus 0 scbus3 target 0 lun 0
cd0: <TSSTcorp DVD+-RW TS-U633A D200> Removable CD-ROM SCSI-0 device
cd0: 150.000MB/s transfers (SATA 1.x, UDMA5, ATAPI 12bytes, PIO 8192bytes)
cd0: Attempt to query device size failed: NOT READY, Medium not present -
tray closed
SMP: AP CPU #1 Launched!
Root mount waiting for: usbus3
Root mount waiting for: usbus3
ugen3.2: <CN0TX5937248794G07SP> at usbus3
Trying to mount root from ufs:/dev/ada0p2 [rw]...
ugen0.2: <Broadcom> at usbus0
uhub8: <Broadcom BCM2046B1, class 9/0, rev 2.00/1.00, addr 2> on usbus0
ugen2.2: <Broadcom Corp> at usbus2
uhub8: 3 ports with 0 removable, self powered
ugen0.3: <vendor 0x413c> at usbus0
ukbd0: <vendor 0x413c product 0x8157, class 0/0, rev 2.00/1.00, addr 3> on
usbus0
kbd2 at ukbd0
ugen0.4: <vendor 0x413c> at usbus0
ums0: <vendor 0x413c product 0x8158, class 0/0, rev 2.00/1.00, addr 4> on
usbus0
ums0: 3 buttons and [XY] coordinates ID=2
wlan0: Ethernet address: 00:21:6a:4b:da:1c
wlan0: link state changed to UP
ugen7.2: <HUAWEI> at usbus7
ugen7.2: <HUAWEI> at usbus7 (disconnected)
ugen7.2: <HUAWEI> at usbus7
umodem0: <HUAWEI HUAWEI Mobile, class 0/0, rev 2.00/1.02, addr 2> on usbus7
umodem0: data interface 0, has no CM over data, has no break
umodem1: <HUAWEI HUAWEI Mobile, class 0/0, rev 2.00/1.02, addr 2> on usbus7
umodem1: data interface 1, has no CM over data, has no break
umodem2: <HUAWEI HUAWEI Mobile, class 0/0, rev 2.00/1.02, addr 2> on usbus7
umodem2: data interface 2, has no CM over data, has no break
umass0: <HUAWEI HUAWEI Mobile, class 0/0, rev 2.00/1.02, addr 2> on usbus7
umass0:  SCSI over Bulk-Only; quirks = 0x0000
umass0:9:0:-1: Attached to scbus9
cd1 at umass-sim0 bus 0 scbus9 target 0 lun 0
cd1: <HUAWEI Mass Storage 2.31> Removable CD-ROM SCSI-2 device
cd1: 40.000MB/s transfers
cd1: Attempt to query device size failed: NOT READY, Medium not present
umass1: <HUAWEI HUAWEI Mobile, class 0/0, rev 2.00/1.02, addr 2> on usbus7
umass1:  SCSI over Bulk-Only; quirks = 0x0000
umass1:10:1:-1: Attached to scbus10
da0 at umass-sim1 bus 1 scbus10 target 0 lun 0
da0: <HUAWEI SD Storage 2.31> Removable Direct Access SCSI-2 device
da0: 40.000MB/s transfers
da0: Attempt to query device size failed: NOT READY, Medium not present

-- usbconfig list output

root@:/root # usbconfig list
ugen0.1: <UHCI root HUB Intel> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen1.1: <UHCI root HUB Intel> at usbus1, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen2.1: <UHCI root HUB Intel> at usbus2, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen3.1: <EHCI root HUB Intel> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=SAVE
ugen4.1: <UHCI root HUB Intel> at usbus4, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen5.1: <UHCI root HUB Intel> at usbus5, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen6.1: <UHCI root HUB Intel> at usbus6, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen7.1: <EHCI root HUB Intel> at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=SAVE
ugen3.2: <LaptopIntegratedWebcam0.3M CN0TX5937248794G07SP> at usbus3, cfg=0
md=HOST spd=HIGH (480Mbps) pwr=ON
ugen0.2: <BCM2046B1 Broadcom> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=SAVE
ugen2.2: <5880 Broadcom Corp> at usbus2, cfg=0 md=HOST spd=FULL (12Mbps)
pwr=ON
ugen0.3: <product 0x8157 vendor 0x413c> at usbus0, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=ON
ugen0.4: <product 0x8158 vendor 0x413c> at usbus0, cfg=0 md=HOST spd=FULL
(12Mbps) pwr=ON
ugen7.2: <HUAWEI Mobile HUAWEI> at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps)
pwr=ON

root@:/root # kldload ucom
kldload: can't load ucom: File exists
root@:/root # kldload u3g
kldload: can't load u3g: File exists
root@:/root # sysctl -a dev.u3g
sysctl: unknown oid 'dev.u3g'
root@:/root #

anyone could give to me some clue.

Thanks in advance.

Saludos / Regards
Leonardo Santagostini



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CADmnP4Nh27_KQBiMi-n7e7EzWzRSnVrZpBuLmTuH=6qvqZon0A>