From owner-svn-src-head@FreeBSD.ORG Thu Jul 8 03:28:25 2010 Return-Path: Delivered-To: svn-src-head@freebsd.org Received: from mx1.freebsd.org (mx1.freebsd.org [IPv6:2001:4f8:fff6::34]) by hub.freebsd.org (Postfix) with ESMTP id B8C48106566C; Thu, 8 Jul 2010 03:28:25 +0000 (UTC) (envelope-from randi@FreeBSD.org) Received: from svn.freebsd.org (svn.freebsd.org [IPv6:2001:4f8:fff6::2c]) by mx1.freebsd.org (Postfix) with ESMTP id A5C928FC16; Thu, 8 Jul 2010 03:28:25 +0000 (UTC) Received: from svn.freebsd.org (localhost [127.0.0.1]) by svn.freebsd.org (8.14.3/8.14.3) with ESMTP id o683SP4s089420; Thu, 8 Jul 2010 03:28:25 GMT (envelope-from randi@svn.freebsd.org) Received: (from randi@localhost) by svn.freebsd.org (8.14.3/8.14.3/Submit) id o683SP5k089410; Thu, 8 Jul 2010 03:28:25 GMT (envelope-from randi@svn.freebsd.org) Message-Id: <201007080328.o683SP5k089410@svn.freebsd.org> From: Randi Harper Date: Thu, 8 Jul 2010 03:28:25 +0000 (UTC) To: src-committers@freebsd.org, svn-src-all@freebsd.org, svn-src-head@freebsd.org X-SVN-Group: head MIME-Version: 1.0 Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8bit Cc: Subject: svn commit: r209787 - head/usr.sbin/sysinstall X-BeenThere: svn-src-head@freebsd.org X-Mailman-Version: 2.1.5 Precedence: list List-Id: SVN commit messages for the src tree for head/-current List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , X-List-Received-Date: Thu, 08 Jul 2010 03:28:25 -0000 Author: randi Date: Thu Jul 8 03:28:25 2010 New Revision: 209787 URL: http://svn.freebsd.org/changeset/base/209787 Log: Remove the ability to upgrade via sysinstall. This feature has been flaky and broken for a number of years. freebsd-update now provides a reasonable way to handle upgrades, so keeping this functionality in sysinstall only serves to mislead users. Approved by: cperciva (mentor) Deleted: head/usr.sbin/sysinstall/installUpgrade.c Modified: head/usr.sbin/sysinstall/Makefile head/usr.sbin/sysinstall/dispatch.c head/usr.sbin/sysinstall/install.c head/usr.sbin/sysinstall/menus.c head/usr.sbin/sysinstall/sysinstall.8 head/usr.sbin/sysinstall/sysinstall.h Modified: head/usr.sbin/sysinstall/Makefile ============================================================================== --- head/usr.sbin/sysinstall/Makefile Thu Jul 8 02:46:42 2010 (r209786) +++ head/usr.sbin/sysinstall/Makefile Thu Jul 8 03:28:25 2010 (r209787) @@ -8,7 +8,7 @@ PROG= sysinstall MAN= sysinstall.8 SRCS= anonFTP.c cdrom.c command.c config.c devices.c dhcp.c \ disks.c dispatch.c dist.c dmenu.c doc.c dos.c floppy.c \ - ftp.c globals.c http.c index.c install.c installUpgrade.c keymap.c \ + ftp.c globals.c http.c index.c install.c keymap.c \ label.c main.c makedevs.c media.c menus.c misc.c modules.c \ mouse.c msg.c network.c nfs.c options.c package.c \ system.c tcpip.c termcap.c ttys.c ufs.c usb.c user.c \ Modified: head/usr.sbin/sysinstall/dispatch.c ============================================================================== --- head/usr.sbin/sysinstall/dispatch.c Thu Jul 8 02:46:42 2010 (r209786) +++ head/usr.sbin/sysinstall/dispatch.c Thu Jul 8 03:28:25 2010 (r209787) @@ -82,7 +82,6 @@ static struct _word { { "installCommit", installCommit }, { "installExpress", installExpress }, { "installStandard", installStandard }, - { "installUpgrade", installUpgrade }, { "installFixupBase", installFixupBase }, { "installFixitHoloShell", installFixitHoloShell }, { "installFixitCDROM", installFixitCDROM }, Modified: head/usr.sbin/sysinstall/install.c ============================================================================== --- head/usr.sbin/sysinstall/install.c Thu Jul 8 02:46:42 2010 (r209786) +++ head/usr.sbin/sysinstall/install.c Thu Jul 8 03:28:25 2010 (r209787) @@ -1032,13 +1032,11 @@ installFilesystems(dialogMenuItem *self) Device **devs; PartInfo *root; char dname[80]; - Boolean upgrade = FALSE; /* If we've already done this, bail out */ if (!variable_cmp(DISK_LABELLED, "written")) return DITEM_SUCCESS; - upgrade = !variable_cmp(SYSTEM_STATE, "upgrade"); if (!checkLabels(TRUE)) return DITEM_FAILURE; @@ -1078,9 +1076,7 @@ installFilesystems(dialogMenuItem *self) if (strcmp(root->mountpoint, "/")) msgConfirm("Warning: %s is marked as a root partition but is mounted on %s", RootChunk->name, root->mountpoint); - if (root->do_newfs && (!upgrade || - !msgNoYes("You are upgrading - are you SURE you want to newfs " - "the root partition?"))) { + if (root->do_newfs) { int i; dialog_clear_norefresh(); @@ -1093,9 +1089,7 @@ installFilesystems(dialogMenuItem *self) } } else { - if (!upgrade) { - msgConfirm("Warning: Using existing root partition."); - } + msgConfirm("Warning: Using existing root partition."); dialog_clear_norefresh(); msgNotify("Checking integrity of existing %s filesystem.", dname); i = vsystem("fsck_ffs -y %s", dname); @@ -1179,9 +1173,7 @@ installFilesystems(dialogMenuItem *self) sprintf(dname, "%s/dev/%s", RunningAsInit ? "/mnt" : "", c2->name); - if (tmp->do_newfs && (!upgrade || - !msgNoYes("You are upgrading - are you SURE you" - " want to newfs /dev/%s?", c2->name))) + if (tmp->do_newfs) performNewfs(tmp, dname, QUEUE_YES); else command_shell_add(tmp->mountpoint, @@ -1214,7 +1206,7 @@ installFilesystems(dialogMenuItem *self) } } else if (c1->type == fat && c1->private_data && - (root->do_newfs || upgrade)) { + (root->do_newfs)) { char name[FILENAME_MAX]; sprintf(name, "%s/%s", RunningAsInit ? "/mnt" : "", ((PartInfo *)c1->private_data)->mountpoint); @@ -1227,9 +1219,7 @@ installFilesystems(dialogMenuItem *self) sprintf(dname, "%s/dev/%s", RunningAsInit ? "/mnt" : "", c1->name); - if (pi->do_newfs && (!upgrade || - !msgNoYes("You are upgrading - are you SURE you want to " - "newfs /dev/%s?", c1->name))) + if (pi->do_newfs) performNewfs(pi, dname, QUEUE_YES); command_func_add(pi->mountpoint, Mount_msdosfs, c1->name); Modified: head/usr.sbin/sysinstall/menus.c ============================================================================== --- head/usr.sbin/sysinstall/menus.c Thu Jul 8 02:46:42 2010 (r209786) +++ head/usr.sbin/sysinstall/menus.c Thu Jul 8 03:28:25 2010 (r209787) @@ -243,7 +243,6 @@ DMenu MenuIndex = { #endif /* WITH_SYSCONS */ { " Time Zone", "Set the system's time zone.", NULL, dmenuSystemCommand, NULL, "tzsetup" }, { " TTYs", "Configure system ttys.", NULL, configEtcTtys, NULL, "ttys" }, - { " Upgrade", "Upgrade an existing system.", NULL, installUpgrade }, { " Usage", "Quick start - How to use this menu system.", NULL, dmenuDisplayFile, NULL, "usage" }, { " User Management", "Add user and group information.", NULL, dmenuSubmenu, NULL, &MenuUsermgmt }, { NULL } }, @@ -275,7 +274,6 @@ DMenu MenuInitial = { #endif { "Options", "View/Set various installation options", NULL, optionsEditor }, { "Fixit", "Repair mode with CDROM/DVD/floppy or start shell", NULL, dmenuSubmenu, NULL, &MenuFixit }, - { "Upgrade", "Upgrade an existing system", NULL, installUpgrade }, { "Load Config..","Load default install configuration", NULL, dispatch_load_menu }, { "Index", "Glossary of functions", NULL, dmenuSubmenu, NULL, &MenuIndex }, { NULL } }, Modified: head/usr.sbin/sysinstall/sysinstall.8 ============================================================================== --- head/usr.sbin/sysinstall/sysinstall.8 Thu Jul 8 02:46:42 2010 (r209786) +++ head/usr.sbin/sysinstall/sysinstall.8 Thu Jul 8 03:28:25 2010 (r209787) @@ -553,11 +553,6 @@ installation type available. .Pp .Sy Variables : None -.It installUpgrade -Start an upgrade installation. -.Pp -.Sy Variables : -None .It installFixitHoloShell Start up the "emergency holographic shell" over on VTY4 if running as init. Modified: head/usr.sbin/sysinstall/sysinstall.h ============================================================================== --- head/usr.sbin/sysinstall/sysinstall.h Thu Jul 8 02:46:42 2010 (r209786) +++ head/usr.sbin/sysinstall/sysinstall.h Thu Jul 8 03:28:25 2010 (r209787) @@ -679,7 +679,6 @@ extern int installFixitUSB(dialogMenuIte extern int installFixitFloppy(dialogMenuItem *self); extern int installFixupBase(dialogMenuItem *self); extern int installFixupKernel(dialogMenuItem *self, int dists); -extern int installUpgrade(dialogMenuItem *self); extern int installFilesystems(dialogMenuItem *self); extern int installVarDefaults(dialogMenuItem *self); extern void installEnvironment(void);