Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 16 Mar 1995 22:41:37 -0500
From:      mull@world.std.com (Kathleen and Chris Mullendore)
To:        questions@FreeBSD.org
Subject:   Having trouble getting a 3com 3c507 Etherlink 16 to be recognized
Message-ID:  <199503170341.AA20974@world.std.com>

Next in thread | Raw E-Mail | Index | Archive | Help
I have configured a used 3c507 as follows:

	I/O Base address	360 Hex
	Interrupt level		7
	Transceiver type	EXTERNAL
	RAM Base Address	0D0000 Hex
	RAM Size		64 KB
	ROM Base Address	0C6000 Hex
	ROM Size		0 KB
	Zero wait state		DISABLED
	Data mode		TURBO

It passes the 3COM Group 1 (internal) and Group 2 (bounce a packet off
the transceiver, I think) diagnostics.  I couldn't run Group 3
(client/server) since I don't have access to another 3com node to set
up as a server.

When I boot FreeBSD 2.0 off the hard disk in order to ftp the
distributions, the card does not get recognized.  I believe the "ie"
driver is the one that should be used.  Below is an excerpt from the
log which appears in full at the end of the mail.

	...
	ie0: can't find shared memory
	ie0 not found at 0x360
	...
	stray irq 7

What am I doing wrong?  Could the card be bad even though it passed
most of the diags?

Thank you.

Chris Mullendore

==================== dmesg.out follows ===================

FreeBSD 2.1.0-Development #0: Sun Dec  4 17:30:34 GMT 1994
    jkh@time.cdrom.com:/usr/src/sys/compile/GENERIC
CPU: i486DX (486-class CPU)
real memory  = 7995392 (1952 pages)
avail memory = 6717440 (1640 pages)
using 120 buffers containing 983040 bytes of memory
Probing for devices on the ISA bus:
sc0 at 0x60-0x6f irq 1 on motherboard
sc0: VGA color <4 virtual consoles>
ed0 not found at 0x280
ed1 not found at 0x300
sio0 at 0x3f8-0x3ff irq 4 on isa
sio0: type 16450
sio1 not found at 0x2f8
sio2 not found at 0x3e8
sio3 not found at 0x2e8
lpt0 not found at 0xffffffff
lpt1 not found at 0xffffffff
lpt2 not found at 0xffffffff
fdc0 at 0x3f0-0x3f7 irq 6 drq 2 on isa
fdc0: [0: fd0: 1.44MB 3.5in]
wdc0 at 0x1f0-0x1f7 irq 14 on isa
wdc0: unit 0 (wd0): <Maxtor 7345 AT>
wd0: 329MB (675450 total sec), 790 cyl, 15 head, 57 sec, bytes/sec 512
wdc0: unit 1 (wd1): <Maxtor 7546 AT>
wd1: 504MB (1032192 total sec), 1024 cyl, 16 head, 63 sec, bytes/sec 512
wdc1 not found at 0x170
bt0 not found at 0x330
uha0 not found at 0x330
ahc0 not found
ahb0 not found
aha0 not found at 0x330
aic0 not found at 0x340
pas0 not found at 0x1f88
sea0 not found
wt0 not found at 0x300
mcd0: timeout getting status
mcd0 not found at 0x300
mcd1: timeout getting status
mcd1 not found at 0x340
ie0: can't find shared memory
ie0 not found at 0x360
ep0 not found at 0x300
is0 not found at 0x280
le0: no board found at 0x300
le0 not found at 0x300
ze0 not found at 0x300
npx0 on motherboard
npx0: 387 Emulator
stray irq 7



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?199503170341.AA20974>