Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 20 Jan 2009 11:13:50 +0200
From:      Valentin Bud <valentin.bud@gmail.com>
To:        freebsd-questions <freebsd-questions@freebsd.org>
Subject:   init: can't exec getty after power failure
Message-ID:  <139b44430901200113i3ab9c5efyd89090666c4dc886@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello list,

I have FreeBSD 7.0-p5 installed on 2 USB drives mirroring with gmirror. I
use
the following partition scheme:
/ - on USB
/var, /usr, /tmp, /home - on internal HDD using ZFS.

 Last night after a power failure the system failed to boot with the
following error:
... can't find /boot/loader.4th. Entered BIOS and changed the first boot
drive to be
the second USB from raid. The system boots but it stops here:

"Trying to mount root from ufs:/dev/mirror/gm0s1a
Loading configuration file
/libexec/ld-elf.so.1: /lib/libutil.so.7: object is not dynamically linked
init: can't exec getty '/usr/libexec' getty for port /dev/ttyv7: No such
file or directory"

ttyv[n] in fact where 'n' takes values from 0 - 7.

Booted into single user mode, fsck-ed the root partition and tried to mount
all the UFS
partitions (/var, /usr) from the USB drive but the mount command fails with
the
"/libexec/ld-elf.so.1: /lib/libutil.so.7: object is not dynamically linked"
error.

Is there anything i can do next besides reinstallation?

thank you very much and a great day,
v



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?139b44430901200113i3ab9c5efyd89090666c4dc886>