Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 22 May 2013 08:32:05 +0200 (CEST)
From:      =?ISO-8859-1?Q?Trond_Endrest=F8l?= <Trond.Endrestol@fagskolen.gjovik.no>
To:        hrkesh sahu <hrisikeshsahu@gmail.com>
Cc:        FreeBSD questions <freebsd-questions@freebsd.org>
Subject:   Re: Fresh installation 9.1
Message-ID:  <alpine.BSF.2.00.1305220825560.72982@mail.fig.ol.no>
In-Reply-To: <CAMB42mzFdMrDqFbRXW5rj8NyK2rwmTKP4C_UOiMirq7YpAMc0A@mail.gmail.com>
References:  <CAMB42mzLT_T7UEsCASZg6AvQ67=6QwVqrtWy_roWPohK4jO1bw@mail.gmail.com> <CAMB42myZvcABC0p167RtDMxF=Qv0rXxpYi_B9EiVz9HQe-niDg@mail.gmail.com> <alpine.BSF.2.00.1305091019190.72982@mail.fig.ol.no> <CAMB42mzFdMrDqFbRXW5rj8NyK2rwmTKP4C_UOiMirq7YpAMc0A@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
  This message is in MIME format.  The first part should be readable text,
  while the remaining parts are likely unreadable without MIME-aware tools.

--2055831798-465747425-1369204325=:72982
Content-Type: TEXT/PLAIN; charset=ISO-8859-1
Content-Transfer-Encoding: 8BIT

On Wed, 22 May 2013 11:10+0530, hrkesh sahu wrote:

> Hi All,
> IPv4 Routing  -
> ------------------------
> I disabled the DHCP from rc.conf for both the interface. but still I am not
> able to route trafic from one interface to another.
> 
> rc.conf
> ---------------
> hostname="idc-freebsd"
> keymap="hy.armscii-8.kbd"
> #ifconfig_re0="DHCP"
> #ifconfig_rl0="DHCP"
> dumpdev="NO"

> ifconfig_rl0="inet 192.168.100.101 netmask 255.255.255.0
> ifconfig_re0="inet 192.168.200.101 netmask 255.255.255.0

Are the two lines above copied straight from your rc.conf file?
If so, both lines are missing a " at the end. Please check to see if 
this is needed.

Next, the outputs of the ifconfig command and the netstat -r command 
should reveal something interesting. Would you please post the 
results from these two commands?

> ipv6_activate_all_interfaces="YES"
> gateway_enable="YES"
> default_router="192.168.200.1"
> 
> I am using FreeBSD - 9.1 Release version
> 
> I need to communicate between two different subnets.
> 
> Am i missing anything to enable freebsd as router?
> Do i need to add a route entry?
> 
> If possible could you please share rc.conf file with IPv4 routing?
> 
> Regards
> Hrisikesh
> 
> On Thu, May 9, 2013 at 2:04 PM, Trond Endrestøl <
> Trond.Endrestol@fagskolen.gjovik.no> wrote:
> 
> > On Thu, 9 May 2013 12:18+0530, hrkesh sahu wrote:
> >
> > > > HI All,
> > > >
> > > I have a FreeBSD 9.1 Release installed with TWO NIC cards. I was trying
> > to
> > > make this FreeBSD machine as a router .
> > > This is my rc.conf
> > > --------------------------------
> > > ifconfig_rl0 = "inet 192.168.100.101 netmask 255.255.255.0"
> > > ifconfig_re0="inet 192.168.200.101 netmask 255.255.255.0"
> > >
> > > gateway_enable = "YES"
> > > ifconfig_rl0 = "DHCP"
> > > ifconfig_re0 = "DHCP"
> > >
> > > defaultrouter = "192.168.100.1"
> > > ipv6_activate_all_interfaces = "YES"
> > > sshd_enable = "YES"
> > > synchronous_dhclient="YES"
> > >
> > > Please help me to establish a IPv4 router.
> > > Both the interfaces are connected to to different laptops with a static
> > IP
> > > address.
> >
> > You should place a # in front of the two lines:
> >
> > > ifconfig_rl0 = "DHCP"
> > > ifconfig_re0 = "DHCP"
> >
> > Next, you probably shouldn't place spaces before and after the equal
> > signs.
> >
> > > Laptop 1 = 192.168.100.102  ( connected to interface rl0) gateway  -
> > > 192.168.100.1
> > >
> > > Laptop 2 = 192.168.200.102 ( connected to interface re0)
> > > ping from Laptop1 -> rl0 is successful
> > > but ping from Laptop1 -> re0 is not successful.
> > >
> > > After this I want to know also How to make this as IPv6 router?
> >
> > See
> > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-ipv6.html
> > .
> >
> > You probably should create a ULA prefix or two, and assign these to
> > your router interfaces. http://www.sixxs.net/tools/grh/ula/ might help
> > you.
> >
> > Something along these lines might help you achieve what you want:
> >
> > ifconfig_rl0_ipv6="inet6 fd8f:d6d0:e6e7:100::1 prefixlen 64"
> > ifconfig_re0_ipv6="inet6 fd44:13de:a366:200::1 prefixlen 64"
> > ipv6_gateway_enable="YES"
> >
> > Finally you probably should configure and enable Router Advertisement
> > and Host Auto Configuration as explained in section 32.11.6 of
> > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-ipv6.html
> > .

-- 
+-------------------------------+------------------------------------+
| Vennlig hilsen,               | Best regards,                      |
| Trond Endrestøl,              | Trond Endrestøl,                   |
| IT-ansvarlig,                 | System administrator,              |
| Fagskolen Innlandet,          | Gjøvik Technical College, Norway,  |
| tlf. mob.   952 62 567,       | Cellular...: +47 952 62 567,       |
| sentralbord 61 14 54 00.      | Switchboard: +47 61 14 54 00.      |
+-------------------------------+------------------------------------+
--2055831798-465747425-1369204325=:72982--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1305220825560.72982>