Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 13 Apr 2016 17:54:47 +0300
From:      Odhiambo Washington <odhiambo@gmail.com>
To:        User Questions <freebsd-questions@freebsd.org>
Subject:   Stuggling with 3.5.16 on FreeBSD-9.3
Message-ID:  <CAAdA2WNMFixnHNwAph5iPxBgqJQBg30sYWfDr7-UGfR__WCo+Q@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi Amos,

I bit the bullet and upgraded my FreeBSD-8.4 -> 9.3.

I am struggling to compile squid-3.5.16. I just have to find a way to make
it compile and run, by all means.

So now here is what happens:


#!/bin/sh
./configure --prefix=/opt/squid-3.5 \
        --enable-removal-policies="lru heap" \
        --disable-epoll \
        --with-pthreads \
        --enable-storeio="ufs diskd rock aufs" \
        --enable-delay-pools \
        --enable-snmp  \
        --with-openssl=/usr \
        --enable-forw-via-db \
        --enable-cache-digests \
        --enable-wccpv2 \
        --enable-follow-x-forwarded-for \
        --with-large-files \
        --enable-esi \
        --enable-kqueue \
        --enable-icap-client \
        --enable-kill-parent-hack \
        --enable-ssl \
        --enable-ssl-crtd \
        --enable-url-rewrite-helpers \
        --enable-xmalloc-statistics \
        --enable-stacktraces \
        --enable-zph-qos \
        --enable-eui \
        --with-nat-devpf \
        --enable-pf-transparent \
        --enable-ipf-transparent \
        --enable-auth \

My config.log output is here: *http://goo.gl/LcV1yN <http://goo.gl/LcV1yN>*

And this is how the compile fails:Making all in negotiate_auth
Making all in kerberos
depbase=`echo negotiate_kerberos_auth.o | sed
's|[^/]*$|.deps/&|;s|\.o$||'`; g++ -DHAVE_CONFIG_H    -I../../..
-I../../../include  -I../../../lib -I../../../src  -I../../../include
 -I/usr/include  -I/usr/include  -I../../../libltdl -I. -I/usr/include
-I/usr/local/include/libxml2 -I/usr/local/include/libxml2 -Wall
-Wpointer-arith -Wwrite-strings -Wcomments -Wshadow -Woverloaded-virtual
-Werror -pipe -D_REENTRANT -I/usr/local/include  -g -O2 -march=native
-I/usr/local/include -MT negotiate_kerberos_auth.o -MD -MP -MF $depbase.Tpo
-c -o negotiate_kerberos_auth.o negotiate_kerberos_auth.cc && mv -f
$depbase.Tpo $depbase.Po
negotiate_kerberos_auth.cc: In function 'int main(int, char* const*)':
negotiate_kerberos_auth.cc:754: error:
'gsskrb5_extract_authz_data_from_sec_context' was not declared in this scope
*** [negotiate_kerberos_auth.o] Error code 1

Stop in
/usr/home/wash/Tools/Squid/3.5/squid-3.5.16/helpers/negotiate_auth/kerberos.
*** [all-recursive] Error code 1

Stop in
/usr/home/wash/Tools/Squid/3.5/squid-3.5.16/helpers/negotiate_auth/kerberos.
*** [all-recursive] Error code 1

Stop in /usr/home/wash/Tools/Squid/3.5/squid-3.5.16/helpers/negotiate_auth.
*** [all-recursive] Error code 1

Stop in /usr/home/wash/Tools/Squid/3.5/squid-3.5.16/helpers.
*** [all-recursive] Error code 1

Stop in /usr/home/wash/Tools/Squid/3.5/squid-3.5.16.



I am getting closer I think.

The initial compile that I had before the upgrade from 8.4 to 9.3 cannot
run. Gives a different error:

2016/04/13 14:12:13| Accepting NAT intercepted SSL bumped HTTPS Socket
connections at local=192.168.55.254:13129 remote=[::] FD 36 flags=41
2016/04/13 14:12:13| Accepting ICP messages on [::]:3130
2016/04/13 14:12:13| Sending ICP messages from [::]:3130
2016/04/13 14:12:13| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.83:50648 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54178 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54166 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54165 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54180 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54179 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54182 FD 14 flags=33
2016/04/13 14:12:14| ERROR: NAT/TPROXY lookup failed to locate original IPs
on local=192.168.55.254:13128 remote=192.168.55.93:54181 FD 14 flags=33

I therefore feel I must compile afresh against FreeBSD-9.3

Your help is highly appreciated.






--
Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254 7 3200 0004/+254 7 2274 3223
"Oh, the cruft."



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAAdA2WNMFixnHNwAph5iPxBgqJQBg30sYWfDr7-UGfR__WCo+Q>