Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 6 Mar 2012 03:56:00 -0500
From:      Mehmet Erol Sanliturk <m.e.sanliturk@gmail.com>
To:        David Naylor <naylor.b.david@gmail.com>
Cc:        freebsd-emulation@freebsd.org, freebsd-questions@freebsd.org
Subject:   Re: Wine-fbsd64 updated to 1.4.rc6 (32bit Wine for 64bit FreeBSD)
Message-ID:  <CAOgwaMv_m8jyEKkpNt9GC9fmfMvTq586ORLwTo_L6vfdLs4Q3w@mail.gmail.com>
In-Reply-To: <201203060736.06948.naylor.b.david@gmail.com>
References:  <201203042116.09255.naylor.b.david@gmail.com> <201203052200.40788.naylor.b.david@gmail.com> <CAOgwaMsLt=3ev386uzsW4kYy12d2rEjdWEFtTxZinrhqWVezcQ@mail.gmail.com> <201203060736.06948.naylor.b.david@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Tue, Mar 6, 2012 at 12:36 AM, David Naylor <naylor.b.david@gmail.com>wrote:

> On Tuesday, 6 March 2012 00:01:48 Mehmet Erol Sanliturk wrote:
> > On Mon, Mar 5, 2012 at 3:00 PM, David Naylor
> <naylor.b.david@gmail.com>wrote:
> > > On Monday, 5 March 2012 14:17:51 Mehmet Erol Sanliturk wrote:
> > > > On Mon, Mar 5, 2012 at 6:55 AM, David Naylor
> > >
> > > <naylor.b.david@gmail.com>wrote:
> > > > > Please include the full error message, also could you please try
> > >
> > > running
> > >
> > > > > those apps in a clean wine prefix.
> > > >
> > > > # pwd
> > > > /root/APPLY/PROGRAMS
> > > >
> > > > # wine x.exe
> > > >
> > > > err : module : LdrInitializeThunk Main exe initialization for
> > > > L"F:\\APPLY\\PROGRAMS\\x.exe" failed , status c0000017
> > >
> > > I have tried to reproduce the error on my side but was unable to.  The
> > > programs that I tested work without error.
> >
> > This means that there are additional parts in your system which they do
> not
> > exist here .
> > Such parts are not added by "pkg_add wine-fbsd64 ..." .
> > I do not have any idea about which parts may be missing .
>
> It could also mean there are extra components on your computer that are
> interfering however using a clean wine prefix (as mentioned below) has
> ruled
> that out.
>
> > > I was expecting more output from wine...  Please see below about using
> a
> > > clean
> > > wine prefix.  Do you use the nvidia graphics driver?  If so please run
> > > (as root), and provide the output:
> > > # sh /usr/local/share/wine/patch-nvidia.sh
> >
> > There is NO nvidia grphics driver . It is Intel DG965WH main board with
> its
> > integrated graphics driver .
>
> That eliminates my only other idea.
>
> > > If nothing fixes your problem then please submit a bug report at
> > > bugs.winehq.org.
> > >
> > > > I could not understand the phrase :
> > > >
> > > > "in a clean wine prefix" .
> > >
> > > To run a program in a clean wine prefix do:
> > > env WINEPREFIX=/tmp/tmp_wine_prefix wine x.exe
> >
> > This is NOT changing the error message . Only drive become Z: .
>
> As mentioned above, eliminates possible extra components causing
> interference.
>
> > > You may need to use winetricks to install some support programs.
> > >
> > > Good luck
> >
> > "winetricks" could NOT be found .
>
> Please see http://wiki.winehq.org/winetricks for details about winetricks.
>

Thanks . After my message , I searched "winetricks" in Google , and find
its links .
I read its list . I think , it will not contain related parts , except ,
perhaps fonts  , comctl .

I have installed fonts , all dll files , run times  , without any effect on
the generated error message .


>
> > I tried wine which is added by
> >
> > pkg_add -r wine
> >
> > from packages
> >
> > in FreeBSD 9.0 RELEASE i386 as it is installed .
> >
> > On the same programs , the message is the same with amd64 message .
>
> To clarify: you tried running the program under an i386 installation of
> FreeBSD and wine gave you the same problem?
>


Yes .

I am using the ( three ) programs in Windows XP continuously and they are
working in there very well .
They are compiled by Delphi .

Previously , in FreeBSD 7.x ( I think 7.0 or 7.1 ) i386 , I have used the
same programs under Wine successfully .



The previous downloads from

wine-fbsd64-1.3.16,1.txz , ...1.3.37,1 ... 1.4.r3,1 ... 1.4.r3,3

series did not work because of errors displayed .


I have tested wine-fbsd64-1.3.16,1.txz now once more .


When the last published one ( 1.4.r4,1 ) also gave error , I decided to
inform you .



>
> Also, has a previous version of wine ever worked for your program?  Could
> you
> try installing an older version of wine (the mediafire page contains wine
> releases going back to 1.3.16).
>
> Regards
>


Thank you very much .

Mehmet Erol Sanliturk



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAOgwaMv_m8jyEKkpNt9GC9fmfMvTq586ORLwTo_L6vfdLs4Q3w>