Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 16 Aug 2012 14:30:42 -0700 (PDT)
From:      "James D. Parra" <jamesp@musicreports.com>
To:        questions@freebsd.org
Subject:   Re: can't build Samba 35 on FreeBSD 9.0
Message-ID:  <91362895.86005.1345152642346.JavaMail.root@mri-mail>
In-Reply-To: <CA+tpaK1wDDOwyGUDFVg3aJ+rHLdy1UMZYTvOakJvb4U0XEOKJQ@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Wed, Aug 15, 2012 at 8:59 PM, James D. Parra < jamesp@musicreports.com > wrote: 

Hello, 

I am trying to install Samba35 on FreeBSD 9.0 but I keep getting a build error. 

The text you gave us gives me the thought you are flailing in the dark. First off, use a port management tool eg portmaster. Learn how to use it fully including regularly reading /usr/ports/UPDATING The handbook has great information on managing ports, I suggest reading it closely if you want FreeBSD to be your friend. 

In this scenario, you would use 

portsnap fetch update(assuming you've once a portsnap extract once before) 
portmaster /usr/ports/net/samba35 

The specific error in your message indicates some problem with ccache. What does your /etc/make.conf look like? 

-- 
Adam Vande More 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thanks all for your replies. I had copied the details from what I had done from, http://forums.freebsd.org/archive/index.php/t-21461.html. I knew what the OP meant so I had issued, portsnap fetch, then portsnap extract, on my system.

I was able to get this to work on FreeBSD 8.2 and was hoping to also get this working on 9.0. Since I will be using Kerberos, I use, 'make KRB5_HOME=/usr/local install clean'. My /etc/make.conf file has the following;

 cat /etc/make.conf
# Uncomment this if you want to do port builds with no interaction
#BATCH=yes
# Keep KDE4 in /usr/local, fixes sharing of icons / mime and others
KDE4_PREFIX=/usr/local
# added by use.perl 2012-06-28 21:39:00
PERL_VERSION=5.12.4
#To build Samba
WITH_ADS=yes
<snip>

I do need ADS as I will be joining this server to our domain.

For reference, here is the build error;
libsmb/libsmb_setget.c: In function 'smbc_getOptionUseCCache':
libsmb/libsmb_setget.c:427: error: 'SMB_CTX_FLAG_USE_CCACHE' undeclared (first use in this function)
libsmb/libsmb_setget.c:427: error: (Each undeclared identifier is reported only once
libsmb/libsmb_setget.c:427: error: for each function it appears in.)
libsmb/libsmb_setget.c: In function 'smbc_setOptionUseCCache':
libsmb/libsmb_setget.c:435: error: 'SMB_CTX_FLAG_USE_CCACHE' undeclared (first use in this function)
The following command failed:
cc -I/usr/local/include -O2 -pipe -DLDAP_DEPRECATED -fno-strict-aliasing -I. -I/usr/ports/net/samba35/work/samba-3.5.15/source3 -I/usr/ports/net/samba35/work/samba-3.5.15/source3/iniparser/src -Iinclude -I./include  -I. -I. -I./../lib/replace -I./../lib/tevent -I./libaddns -I./librpc -I./.. -DHAVE_CONFIG_H  -I/usr/local/include -I/usr/local/include -Iinclude -I./include -I. -I. -I./../lib/replace -I./../lib/tevent -I./libaddns -I./librpc -I./.. -I./../lib/popt -I/usr/local/include -DLDAP_DEPRECATED  -I/usr/ports/net/samba35/work/samba-3.5.15/source3/lib -I.. -I../source4 -D_SAMBA_BUILD_=3 -D_SAMBA_BUILD_=3  -fPIC -DPIC -c libsmb/libsmb_setget.c -o libsmb/libsmb_setget.o
gmake: *** [libsmb/libsmb_setget.o] Error 1
*** Error code 1

Stop in /usr/ports/net/samba35.
*** Error code 1

Stop in /usr/ports/net/samba35.
<snip>

Thanks for your help.

James 



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?91362895.86005.1345152642346.JavaMail.root>