Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 29 Jun 2006 16:30:02 -0700
From:      "Kevin Oberman" <oberman@es.net>
To:        current@freebsd.org
Subject:   Unable to build acpi_asus module on current today
Message-ID:  <20060629233003.0188145043@ptavv.es.net>

Next in thread | Raw E-Mail | Index | Archive | Help
Today I tried rebuilding my laptop running current. Building the kernel
module acpi_asus, the build bombed with the error:
===> acpi_asus (all)
cc -O2 -fno-strict-aliasing -pipe -Werror -D_KERNEL -DKLD_MODULE -nostdinc -I-
-I/usr/src/sys/modules/acpi/acpi_asus/../../../contrib/dev/acpica -I. -I@ -I@/contrib/altq -finline-limit=8000 --param inline-unit-growth=100 --param large-function-growth=1000 -fno-common  -mno-align-long-strings -mpreferred-stack-boundary=2  -mno-mmx -mno-3dnow -mno-sse -mno-sse2 -mno-sse3 -ffreestanding -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual  -Wundef -fformat-extensions -c /usr/src/sys/modules /acpi/acpi_asus/../../../dev/acpi_support/acpi_asus.c
/usr/src/sys/modules/acpi/acpi_asus/../../../dev/acpi_support/acpi_asus.c: In function `acpi_asus_attach':
/usr/src/sys/modules/acpi/acpi_asus/../../../dev/acpi_support/acpi_asus.c:584: error: 'for' loop initial declaration used outside C99 mode

But this module has not been touched since April and I have built all of
it many times since then. Several other modules seem to have the same
problem of declaring a variable in a for statement.

I moved the declaration to its own statement before the "for" and it
compiles fine.

Did some compiler default recently change? I have no compile options on my
make.conf.
-- 
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman@es.net			Phone: +1 510 486-8634



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20060629233003.0188145043>