Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 12 Dec 2020 03:14:07 +0000
From:      Graham Perrin <grahamperrin@gmail.com>
To:        FreeBSD questions <freebsd-questions@freebsd.org>
Cc:        Hans Petter Selasky <hps@selasky.org>
Subject:   virtual_oss: Could not create CUSE DSP device
Message-ID:  <3da4613d-fdf7-6fbe-baae-1f998724e31f@gmail.com>
In-Reply-To: <96ce7276-6ec1-c87c-ca08-4a24b671a5d7@gmail.com>
References:  <96ce7276-6ec1-c87c-ca08-4a24b671a5d7@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 07/12/2020 00:39, Graham Perrin wrote:
> virtual_oss(8)
> <https://www.freebsd.org/cgi/man.cgi?query=virtual_oss&sektion=8&manpath=Ports>; 
>
>
> Below, please, what am I doing wrong?
>
> I use analogue by default (when the notebook starts), I sometimes 
> connect a USB headset.
>
> ----
>
> $ whoami
> grahamperrin
…
> $ virtual_oss -C 2 -c 2 -r 48000 -b 24 -s 8.0ms -f /dev/dsp3 -d dsp
> virtual_oss: Could not connect to cuse module

…


As root there's a different result:


grahamperrin@mowa219-gjp4-8570p:~ % sudo service virtual_oss status
grahamperrin's password:
virtual_oss is running as pid 116.
grahamperrin@mowa219-gjp4-8570p:~ % cat /dev/sndstat
Installed devices:
pcm0: <ATI R6xx (HDMI)> (play)
pcm1: <IDT 92HD81B1X (Analog 2.0+HP/2.0)> (play/rec) default
pcm2: <IDT 92HD81B1X (Analog)> (play/rec)
pcm3: <USB audio> (play/rec)
Installed devices from userspace:
dsp: <Virtual OSS> (play/rec)
grahamperrin@mowa219-gjp4-8570p:~ % sudo virtual_oss -C 2 -c 2 -r 48000 
-b 24 -s 8.0ms -f /dev/dsp3 -d dsp
hw.snd.basename_clone: 0 -> 0
virtual_oss: Could not create CUSE DSP device
grahamperrin@mowa219-gjp4-8570p:~ %




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?3da4613d-fdf7-6fbe-baae-1f998724e31f>