Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 22 May 2013 09:33:42 +0200 (CEST)
From:      =?ISO-8859-1?Q?Trond_Endrest=F8l?= <Trond.Endrestol@fagskolen.gjovik.no>
To:        hrkesh sahu <hrisikeshsahu@gmail.com>
Cc:        FreeBSD questions <freebsd-questions@freebsd.org>
Subject:   Re: Fresh installation 9.1
Message-ID:  <alpine.BSF.2.00.1305220925560.72982@mail.fig.ol.no>
In-Reply-To: <CAMB42mwjMoOsjdDVUyo8dazym63atBfySFt4E38Kbd2vq0e9Gw@mail.gmail.com>
References:  <CAMB42mzLT_T7UEsCASZg6AvQ67=6QwVqrtWy_roWPohK4jO1bw@mail.gmail.com> <CAMB42myZvcABC0p167RtDMxF=Qv0rXxpYi_B9EiVz9HQe-niDg@mail.gmail.com> <alpine.BSF.2.00.1305091019190.72982@mail.fig.ol.no> <CAMB42mzFdMrDqFbRXW5rj8NyK2rwmTKP4C_UOiMirq7YpAMc0A@mail.gmail.com> <alpine.BSF.2.00.1305220825560.72982@mail.fig.ol.no> <CAMB42mwjMoOsjdDVUyo8dazym63atBfySFt4E38Kbd2vq0e9Gw@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
  This message is in MIME format.  The first part should be readable text,
  while the remaining parts are likely unreadable without MIME-aware tools.

--2055831798-540096040-1369208022=:72982
Content-Type: TEXT/PLAIN; charset=ISO-8859-1
Content-Transfer-Encoding: 8BIT

On Wed, 22 May 2013 12:38+0530, hrkesh sahu wrote:

> Hi ,
> Thanks a lot for this quick reply.
> Sorry i missed the " in the end while typing. It's a typo.
> I provided the ouput of " nestat -r " and "ifconfig".
> 
> > netstat -r
> --------------
> routing tables  -
> 
> internet :
> -----------
> destination                   Gateway
> Flags                       Refs
> Use                               Netif Expire
> default                         192.168.200.1
> UGS                       0
> 0                                  re0
> localhost                      link#12
> UH                         0
> 148                               lo0
> 192.168.100.0              link#10
> U                           0
> 0                                   rl0
> 192.168.100.101           link#10                      UHS
>                      0
> 0                                   lo0
> 192.168.200.0              link#5
> U                           0
> 0                                   re0
> 192.168.200.101           link#5                      UHS
>                        0
> 0                                   lo0
> 
> Internet6:
> -------------------
> Ipv6 details
> 
> > Ifconfig
> --------------------
> re0: flags=8843<UP,Broadcast,Running,Simplex,Multicast> Metric 0 mtu 1500
> options=8209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>
> ether 00:1f:d0:40:8b:bd
> inet6 fe80::21f:d0ff:fe40:8bbd%re0 prefixlen 64 scopeid 0x5
> inet 192.168.200.101 netmask 0xffffff00         broadcast 192.168.200.255
> nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
> media:Enthernet autoselect (none)
> status: no carrier
> 
> rl0: flags=8843<UP,Broadcast,Running,Simplex,Multicast> Metric 0 mtu 1500
> options=2008<VLAN_MTU,WOL_MAGIC>
> ether 00:10:b5:48:9f:73
> inet6 fe80::21f:b5ff:fe48:9f73%rl0 prefixlen 64 scopeid 0xa
> inet 192.168.100.101 netmask 0xffffff00         broadcast 192.168.100.255
> nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
> media:Enthernet autoselect (none)
> status: no carrier
> 
> there is a plip0 and lo0.

Neither NIC is connected to any equipment, e.g. switch, hub, or 
computer (status: no carrier). Make sure you can use a straight 
network cable, else you'll need to get a couple of cross wired network 
cables and use those instead.

Next, confirm the sysctl net.inet.ip.forwarding is set to 1 by
running the sysctl net.inet.ip.forwarding command.

If not, you can set the sysctl to 1 by running the sysctl 
net.inet.ip.forwarding=1 command, and you probably should inspect the 
/etc/rc.conf file one more time.

Once you connect the computer to the two networks, the IPv4 routing 
should work. If not, come back.

> Regards
> Hrisikesh
> 
> On Wed, May 22, 2013 at 12:02 PM, Trond Endrestøl <
> Trond.Endrestol@fagskolen.gjovik.no> wrote:
> 
> > On Wed, 22 May 2013 11:10+0530, hrkesh sahu wrote:
> >
> > > Hi All,
> > > IPv4 Routing  -
> > > ------------------------
> > > I disabled the DHCP from rc.conf for both the interface. but still I am
> > not
> > > able to route trafic from one interface to another.
> > >
> > > rc.conf
> > > ---------------
> > > hostname="idc-freebsd"
> > > keymap="hy.armscii-8.kbd"
> > > #ifconfig_re0="DHCP"
> > > #ifconfig_rl0="DHCP"
> > > dumpdev="NO"
> >
> > > ifconfig_rl0="inet 192.168.100.101 netmask 255.255.255.0
> > > ifconfig_re0="inet 192.168.200.101 netmask 255.255.255.0
> >
> > Are the two lines above copied straight from your rc.conf file?
> > If so, both lines are missing a " at the end. Please check to see if
> > this is needed.
> >
> > Next, the outputs of the ifconfig command and the netstat -r command
> > should reveal something interesting. Would you please post the
> > results from these two commands?
> >
> > > ipv6_activate_all_interfaces="YES"
> > > gateway_enable="YES"
> > > default_router="192.168.200.1"
> > >
> > > I am using FreeBSD - 9.1 Release version
> > >
> > > I need to communicate between two different subnets.
> > >
> > > Am i missing anything to enable freebsd as router?
> > > Do i need to add a route entry?
> > >
> > > If possible could you please share rc.conf file with IPv4 routing?
> > >
> > > Regards
> > > Hrisikesh
> > >
> > > On Thu, May 9, 2013 at 2:04 PM, Trond Endrestøl <
> > > Trond.Endrestol@fagskolen.gjovik.no> wrote:
> > >
> > > > On Thu, 9 May 2013 12:18+0530, hrkesh sahu wrote:
> > > >
> > > > > > HI All,
> > > > > >
> > > > > I have a FreeBSD 9.1 Release installed with TWO NIC cards. I was
> > trying
> > > > to
> > > > > make this FreeBSD machine as a router .
> > > > > This is my rc.conf
> > > > > --------------------------------
> > > > > ifconfig_rl0 = "inet 192.168.100.101 netmask 255.255.255.0"
> > > > > ifconfig_re0="inet 192.168.200.101 netmask 255.255.255.0"
> > > > >
> > > > > gateway_enable = "YES"
> > > > > ifconfig_rl0 = "DHCP"
> > > > > ifconfig_re0 = "DHCP"
> > > > >
> > > > > defaultrouter = "192.168.100.1"
> > > > > ipv6_activate_all_interfaces = "YES"
> > > > > sshd_enable = "YES"
> > > > > synchronous_dhclient="YES"
> > > > >
> > > > > Please help me to establish a IPv4 router.
> > > > > Both the interfaces are connected to to different laptops with a
> > static
> > > > IP
> > > > > address.
> > > >
> > > > You should place a # in front of the two lines:
> > > >
> > > > > ifconfig_rl0 = "DHCP"
> > > > > ifconfig_re0 = "DHCP"
> > > >
> > > > Next, you probably shouldn't place spaces before and after the equal
> > > > signs.
> > > >
> > > > > Laptop 1 = 192.168.100.102  ( connected to interface rl0) gateway  -
> > > > > 192.168.100.1
> > > > >
> > > > > Laptop 2 = 192.168.200.102 ( connected to interface re0)
> > > > > ping from Laptop1 -> rl0 is successful
> > > > > but ping from Laptop1 -> re0 is not successful.
> > > > >
> > > > > After this I want to know also How to make this as IPv6 router?
> > > >
> > > > See
> > > >
> > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-ipv6.html
> > > > .
> > > >
> > > > You probably should create a ULA prefix or two, and assign these to
> > > > your router interfaces. http://www.sixxs.net/tools/grh/ula/ might help
> > > > you.
> > > >
> > > > Something along these lines might help you achieve what you want:
> > > >
> > > > ifconfig_rl0_ipv6="inet6 fd8f:d6d0:e6e7:100::1 prefixlen 64"
> > > > ifconfig_re0_ipv6="inet6 fd44:13de:a366:200::1 prefixlen 64"
> > > > ipv6_gateway_enable="YES"
> > > >
> > > > Finally you probably should configure and enable Router Advertisement
> > > > and Host Auto Configuration as explained in section 32.11.6 of
> > > >
> > http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-ipv6.html
> > > > .

-- 
+-------------------------------+------------------------------------+
| Vennlig hilsen,               | Best regards,                      |
| Trond Endrestøl,              | Trond Endrestøl,                   |
| IT-ansvarlig,                 | System administrator,              |
| Fagskolen Innlandet,          | Gjøvik Technical College, Norway,  |
| tlf. mob.   952 62 567,       | Cellular...: +47 952 62 567,       |
| sentralbord 61 14 54 00.      | Switchboard: +47 61 14 54 00.      |
+-------------------------------+------------------------------------+
--2055831798-540096040-1369208022=:72982--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1305220925560.72982>