Skip site navigation (1)Skip section navigation (2)
Date:      3 Jan 2020 15:57:51 -0500
From:      "John Levine" <johnl@iecc.com>
To:        freebsd-questions@freebsd.org
Cc:        uklyfe14@gmail.com
Subject:   Re: FreeBSD12 and OpenSSL 1.0.2
Message-ID:  <20200103205751.DCBC711F1DBB@ary.qy>
In-Reply-To: <CAEWz_YHoyEHF2yDzZCdxnmdsgOkKabZJKPqzqB0XmQqT36A15g@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
In article <CAEWz_YHoyEHF2yDzZCdxnmdsgOkKabZJKPqzqB0XmQqT36A15g@mail.gmail.com> you write:
>We recently purchased the support of OpenSSL 1.0.2 to extend support for
>our software through OpenSSL’s deprecation while we test functionality and
>compatibility with upgrading our software platform from FreeBSD 11 to 12.
>Would you be able to tell me if and for how long- FreeBSD 12 will be
>compatible with OpenSSL 1.0.2? We do intend to upgrade both packages but
>need to know the timeline given the constraint of our need to upgrade
>OpenSSL 1.0.2.

There's an openssl-unsafe port that provides 1.0.2 for Freebsd 12 if
you really need it.

Since FreeBSD 11 will be supported for another year and a half, my
advice would be to stick with 11.x while you upgrade your software to
openssl 1.1.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20200103205751.DCBC711F1DBB>