Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 9 Aug 2018 11:19:57 -0700
From:      David Newman <dnewman@networktest.com>
To:        freebsd-questions@freebsd.org
Subject:   Re: xrdp configuration and xfce4
Message-ID:  <75bc60f0-07f9-0448-391e-24a522c0f645@networktest.com>
In-Reply-To: <alpine.BSF.2.20.1808081808590.50032@fledge.watson.org>
References:  <d3534b9a-4061-5f6b-e94c-68646700f194@networktest.com> <caf921f910fe2dec5d4a6ed19e682cef@freebsd.org> <7d12e2d7-e8e6-53d0-3c62-d3ca8868f9be@networktest.com> <20180808013151.sia5lgegjcxu2pr3@icepick.vmeta.jp> <3d2a1aa3-94de-e4e7-bb1d-a54ff7a92f94@networktest.com> <b30465dd-4a7e-a9fc-6bf1-ae41b8da3a93@yandex.com> <2a4a6b24-b0ec-a1e8-2e52-00cf1703e193@networktest.com> <d6258fbd-7646-4493-b39b-492abc9b60e9@yandex.com> <52e2c421-e766-859e-3331-92aeb0c9921e@networktest.com> <alpine.BSF.2.20.1808081808590.50032@fledge.watson.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help


On 8/8/18 3:22 PM, doug wrote:
> On Wed, 8 Aug 2018, David Newman wrote:
>=20
>> On 8/8/18 12:16 PM, Oleg Cherkasov wrote:
>>> On 08. aug. 2018 19:57, David Newman wrote:
>>>> On 8/8/18 9:32 AM, Oleg Cherkasov wrote:
>>>>> On 08. aug. 2018 04:10, David Newman wrote:
>>>>
>>>> Previously the .xsession file was just 'startxfce4'.
>>>>
>>>> But adding the '#! /bin/sh' line and restarting xrdp did not change =
the
>>>> behavior: It's still a black screen with one xterm, and no xfce4
>>>> desktop
>>>> or copy/paste support.
>>>>
>>>> Of course startxfce4 will run manually from the xterm but along with
>>>> copy/paste, those are the problems I'm looking to solve.
>>>
>>> I think it was another in X called ~/.xinitrc, just give it a try.
>>
>> That file previously had these contents:
>>
>> exec /usr/local/bin/startxfce4 --with-ck-launch
>>
>> Changing this to just:
>>
>> startxfce4
>>
>> and restarting the xrdp service did not result in xfce4 starting by
>> itself or copy/paste being enabled.
>>
>> It's possible FreeBSD-specific changes are needed to xrdp.ini,
>> startwm.sh, and maybe other config files, but I don't know what those
>> changes are.
>=20
> Do you have physical access to the FreeBSD system?=20

Didn't mention before, but this is a VM running in VMware vSphere. I
have ssh and virtual console access. I don't think the VM part is
relevant since xfce4 and copy-paste worked on the same VM prior to the
upgrade from xrdp 0.6.x to 0.9.x (and again, the root problem here is my
failure to back up configs before the upgrade).


>If so look at
> .xsession-errors in your home dir. In /var/log you will have Xorg.0.log
> and some other simiarly name files. It seemed like getting xfce started
> was at least part of the problem. If not, sorry for the noise.

Sorry, but there's no .xsession-errors file in the home directory.



>=20
> I use xdm with my .xsession as follows:
>=20
> artemis:~> cat .xsession
> #!/bin/sh
> /usr/bin/ssh-agent /usr/local/bin/startxfce4
>=20
> startxfce4 from the console login also works. I do not have any other
> user defined files.

Interesting. startxfce4 from the console login also works for me, but
without copy/paste support.

I'm going to try Iwao-san's suggestion about startwm.sh and will report
back.

dn




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?75bc60f0-07f9-0448-391e-24a522c0f645>