Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 2 Oct 2006 18:14:25 -0400
From:      "Michael Johnson" <ahze@ahze.net>
To:        "Andriy Babiy" <andriyb@desmaint.com>
Cc:        freebsd-questions@freebsd.org, Beni <beni@brinckman.info>
Subject:   Re: portupgrading multimedia/x264
Message-ID:  <b2203fed0610021514i5c19a094q71e82ddf600823a6@mail.gmail.com>
In-Reply-To: <540EE4AEDEEAE3418715F9B95446582D7FE6D4@groucho.dmsivan.com>
References:  <540EE4AEDEEAE3418715F9B95446582D7FE6D4@groucho.dmsivan.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 10/2/06, Andriy Babiy <andriyb@desmaint.com> wrote:
>
> I'm experiencing the same problem. When I do:
> portupgrade -R x264
> the patch fails to apply.
> Mplayer port cannot be upgraded too for the same reason.


update ports, its fixed now. sorry


Message: 13
> Date: Sun, 1 Oct 2006 11:08:32 +0200
> From: Beni <beni@brinckman.info>
> Subject: portupgrading multimedia/x264 : patch failed to apply cleanly
> To: freebsd-questions@freebsd.org
> Message-ID: <200610011108.33162.beni@brinckman.info>
> Content-Type: text/plain;  charset="utf-8"
>
> Hello List,
>
> When trying to portupgrade multimedia/x264 I get an error message :
> "patch
> failed to apply cleanly". I just ran a "portsnap fetch update", so my
> ports
> should be up to date. What is the remedy here ?
>
> Thanks for any help.
>
> Beni.
>
> www# make reinstall
> ===>  Vulnerability check disabled, database not found
> ===>  Found saved configuration for x264-0.0.20060112_1
> => x264-snapshot-20060926-2245.tar.bz2 doesn't seem to exist
> in /usr/ports/distfiles/.
> => Attempting to fetch from
> http://downloads.videolan.org/pub/videolan/x264/snapshots/.
> x264-snapshot-20060926-2245.tar.bz2           100% of  533 kB  351 kBps
> ===>  Extracting for x264-0.0.20060926_1
> => MD5 Checksum OK for x264-snapshot-20060926-2245.tar.bz2.
> => SHA256 Checksum OK for x264-snapshot-20060926-2245.tar.bz2.
> ===>  Patching for x264-0.0.20060926_1
> ===>  Applying FreeBSD patches for x264-0.0.20060926_1
> 1 out of 1 hunks failed--saving rejects to encoder/ratecontrol.c.rej
> => Patch patch-encoder_ratecontrol.c failed to apply cleanly.
> => Patch(es) patch-Makefile patch-configure applied cleanly.
> *** Error code 1
>
> Stop in /usr/ports/multimedia/x264.
> *** Error code 1
>
> Stop in /usr/ports/multimedia/x264.
>
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe@freebsd.org"
>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?b2203fed0610021514i5c19a094q71e82ddf600823a6>