Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 06 Mar 2017 17:31:38 +0100
From:      "Herbert J. Skuhra" <herbert@mailbox.org>
To:        freebsd-questions@freebsd.org
Cc:        Matthew Seaman <matthew@FreeBSD.org>
Subject:   Re: Deprecated Package Dependency... what now?
Message-ID:  <86varmz7rp.wl-herbert@mailbox.org>
In-Reply-To: <092916dc-cb42-a0f0-cb2f-0deb7d95012c@FreeBSD.org>
References:  <CAOEVnYvh7g=6616ueVD8kkkaH+gC8_0iF5p8b_djwWXTVTa=Nw@mail.gmail.com> <092916dc-cb42-a0f0-cb2f-0deb7d95012c@FreeBSD.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Matthew Seaman skrev:
> 
> On 05/03/2017 15:36, Christofer C. Bell wrote:
>> I'm not sure how to proceed here.  I use git on my system.  It depends on
>> package p5-Net-SMTP-SSL-1.04.  This package is set to expire and be
>> removed.  For information on my system, I'm using FreeBSD 11.0-RELEASE-p8,
>> amd64, and all binary packages (not ports).
>> 
>> From the daily security report:
>> 
>> Checking for packages with security vulnerabilities:
>> p5-Net-SMTP-SSL-1.04: Tag: expiration_date Value: 2017-03-31
>> p5-Net-SMTP-SSL-1.04: Tag: deprecated Value: Deprecated by upstream, use
>> Net::SMTP instead
>> 
>> Here's where I can see that git depends on this:
>> 
>> $ pkg info -D p5-Net-SMTP-SSL-1.04
>> p5-Net-SMTP-SSL-1.04:
>> Always:
>> ===>   NOTICE:
>> 
>> This port is deprecated; you may wish to reconsider installing it:
>> 
>> Deprecated by upstream, use Net::SMTP instead.
>> 
>> It is scheduled to be removed on or after 2017-03-31.
> 
> Yes, the functionality of the Net::SMTP::SSL perl module has been rolled
> into Net::SMTP.  However, git upstream are apparently reluctant to patch
> the one included perl script that is affected because they don't want to
> break compatibility with some Linux distribution that has not updated
> their perl modules for several years.
> 
> There are patches floating about to fix that one script in git -- not
> sure whats happening with regard to getting those committed to the ports
> tree.  Even if those patches don't get committed, the lifetime of
> p5-Net-SMTP-SSL would be extended instead: the git port is too simply
> important to be allowed to be broken.

The port is already patched:

r431794 | garga | 2017-01-18 13:40:53 +0100 (ons., 18 jan. 2017) | 6 lines

Remove dependency of DEPRECATED mail/p5-Net-SMTP-SSL from devel/git

PR:             214335
Obtained from:  git development mailing list
Sponsored by:   Rubicon Communications (Netgate)

But MFH is missing in the quartely branch.

--
Herbert



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?86varmz7rp.wl-herbert>