Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 27 Mar 2013 17:37:32 +0100
From:      Loic Capdeville <lolox-freebsd@lolox.net>
To:        Volodymyr Kostyrko <c.kworr@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Upgrade devel/py-setuptools
Message-ID:  <5153204C.6080905@lolox.net>
In-Reply-To: <51531E91.7000306@gmail.com>
References:  <5152E47B.6080904@lolox.net> <5152EB33.4010009@gmail.com> <5152ED8B.8080408@lolox.net> <5152EEBC.20805@lolox.net> <5152F3AE.3010604@gmail.com> <5152F513.3040205@lolox.net> <51531E91.7000306@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 27/03/2013 17:30, Volodymyr Kostyrko wrote:
> 2013-03-27 15:33, Loic Capdeville wrote:
>> On 27/03/2013 14:27, Volodymyr Kostyrko wrote:
>>> 2013-03-27 15:06, Loic Capdeville wrote:
>>>> /usr/local/lib/python2.7/site-packages/easy-install.pth:
>>>>
>>>> import sys; sys.__plen = len(sys.path)
>>>> ../setuptools-0.6c11-py2.7.egg
>>>> ../Pygments-1.5-py2.7.egg
>>>> ../Babel-0.9.6-py2.7.egg
>>>> ../MarkupSafe-0.15-py2.7-freebsd-9.0-RELEASE-amd64.egg
>>>> ../Jinja2-2.6-py2.7.egg
>>>> ../Sphinx-1.1.3-py2.7.egg
>>>> ../virtualenv-1.9.1-py2.7.egg
>>>> import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:];
>>>> p=getattr(sys,'__egginsert',0); sys.path[p:p]=new; sys.__egginsert =
>>>> p+len(new)
>>>>
>>>>
>>>> /usr/local/lib/python2.7/site-packages/easy-install.pth.dist:
>>>>
>>>> import sys; sys.__plen = len(sys.path)
>>>> ../setuptools-0.6c11-py2.7.egg
>>>> import sys; new=sys.path[sys.__plen:]; del sys.path[sys.__plen:];
>>>> p=getattr(sys,'__egginsert',0); sys.path[p:p]=new; sys.__egginsert =
>>>> p+len(new)
>>>
>>> Looks like py-distribute is not installed at all.
>>>
>>> what was the outcome of "portupgrade -fo devel/py-distribute
>>> devel/py-setuptools"? Can you try running that again?
>>>
>>
>> It hasn't printed anything since the first time I tried to run it...
>> and still print nothing.
>
> So here is a main problem. If it prints nothing it doesn't work.
>
> Do you have portupgrade or portmaster installed? Did it yield at least
> one line? Some errors? If it doesn't that's surely a sign that something
> is going wrong.
>
I use portupgrade regularly to upgrade my ports, and usually everything 
goes right.
If fails only with that particular operation (or these portupgrade options)
Do I have to install "devel/py-distribute" separately, or should the 
"portupgrade -fo" command do everything itself (uninstall py-setuptools 
and install py-distribute) ?



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5153204C.6080905>