Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 07 Feb 2012 15:44:25 +1000
From:      Da Rock <freebsd-questions@herveybayaustralia.com.au>
To:        freebsd-questions@freebsd.org
Subject:   impossible? postfix filter && partial virtual domain mailboxes
Message-ID:  <4F30BA39.6010807@herveybayaustralia.com.au>

Next in thread | Raw E-Mail | Index | Archive | Help
I have a postfix mta (beauty mate!) and I've managed to twist its 
panties into a real tight knot by using a filter (smtpd), and through 
using it to put my isp mail into a local box thanks to fetchmail.

The problem I'm facing is that it now won't send mail to any other users 
on my isp's domain. I did manage to get it working _before_ I put the 
filter on, I used vtransport tables to tell it to deliver via smtp 
except _my_ address.

Other than that it works fine, and the problem doesn't come up often- 
usually just about the time I need to complain to my isp (says a lot 
about their service, doesn't it?), maybe once a year?

One thing that did raise my eyebrow when I put the filter in was the 
receive_override_options, which is set to no_address_mappings. Could 
this be the issue?

What would make me happier is to deliver directly via maildrop, but that 
raises a lot of other issues... I'd have to figure out how to access the 
mail via courier, shared folders, etc. I'm not sure that would be 
worthwhile.

Thoughts?

TIA



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F30BA39.6010807>