Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 26 Nov 2004 12:56:57 +0100
From:      "craig" <craig@small-pla.net>
To:        <freebsd-hardware@freebsd.org>, <freebsd-questions@freebsd.org>
Subject:   WRITE_DMA failures on 5.3 (but NOT on 4.10)
Message-ID:  <000001c4d3af$0dd69240$6500a8c0@jupiter>

Next in thread | Raw E-Mail | Index | Archive | Help
hi,

i wrote about this issue some weeks back, but have still not yet =
adequately
resolved it.
(http://lists.freebsd.org/mailman/htdig/freebsd-questions/2004-November/0=
638
07.html)

i have, however, done more testing and found some interesting results.

first off, i am working off the following:
Asrock PE-Pro-HT motherboard with Intel P4 2.6Gh
onboard IDE controller <SiS 5591 ATA33>
on IDE band 1 (80pin) is a Hitachi 80GB drive and a brandX cd/dvd player
on IDE band 2 (80pin) is a ??? 120GB drive and a brandX cd/dvd burner

also nvidia AGP graphics card, and one or two other cards.
(full dmesg from 4.10 at the bottom)

to repeat the original problem, when installing 5.3R it fails about 12% =
into
extracting base into \
on the emergency terminal, there is a stream of warnings and failures
reading:

WARNING : WRITE_DMA UDMA ICRC ERROR <LBA..... blah
FAILURE : WRITE_DMA status =3D 51<Ready, DSC, error>... blah =20

this continues until i run out of patience.

the advice i received was :

* that there may be drive errors
i downloaded a low level disk checking utility from hitachi which =
confirmed
no errors with disk.
also, it is a fairly new disk so it shouldn't be failing now. further, =
it
had not giving any
indications of problems under 4.10

* that the IDE cables, pins, power, jumpers, may be gammy.
i went out and purchased new IDE bands, double checked the rest - no =
visible
problem.

* that the media (cd) from which i was installing may be corrupt
i have checked the md5 sums of the iso and disk, and all is fine.
i have also burnt to two different types of cds, with two different
applications. no change.


getting desperate for other options, i installed ubuntu linux with
absolutely no problem.
looking in ubutu's dmesg indicated no troubles with the disk.
ditto with windows xp.=20

i then reinstalled freebsd 4.10 with absolutely no problems.
i need to make this point very clear - on *exactly* the same hardware, =
under
*exactly* the same circumstances=20
4.10 installs without *any* problems, while 5.3 *fails*!!
(dmesg is included below)

finally, in one of the many permutations of my hardware configurations, =
i
got 5.3 to install.
this i managed to do by disconnecting the cd/dvd player on the first IDE
band (ie. shared with boot drive)

even so, the emergency terminal still gives many of the WRITE_DMA =
warnings,
but fewer failures.
and once installed, any significant amount of disk activity causes more
warnings and occasional failures to pop up.

disk performance has also been *severely* hit! a port install which =
takes no
more than a few minutes on 4.10, ran for hours before i killed it.


this is not an issue with my hardware. this is an issue with 5.3

i have seen several other mentions of this, but with no solutions that
helped me.


any help would be greatly appreciated.

much thanks,


-----------------------
dmesg from freebsd 4.10
-----------------------

Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 4.10-RELEASE #0: Tue May 25 22:52:21 GMT 2004
    root@perseus.cse.buffalo.edu:/usr/obj/usr/src/sys/BOOTMFS
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 2404107844 Hz
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2404.11-MHz 686-class CPU)
  Origin =3D "GenuineIntel"  Id =3D 0xf27  Stepping =3D 7
=20
Features=3D0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PG=
E,MCA
,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory  =3D 1073676288 (1048512K bytes)
config> intro
\^[[m\^[[H\^[[J\^[[3;26H\^[[m\^[[1m\^[[m\^[[6;11H\^[[m\^[[7m\^[[m\^[[7;11=
H\^
[[m\^[[8;11H\^[[m\^[[11;3H\^[[m\^[[12;3H\^[[m\^[[13;3H\^[[m\^[[15;3H\^[[m=
\^[
[16;3H\^[[m\^[[18;3H\^[[m\^[[19;3H\^[[m\^[[21;3H\^[[m\^[[7m\^[[m\^[[22;3H=
\^[
[m\^[[1;1H\^[[6;11H\^[[m\^[[7;11H\^[[m\^[[7m\^[[m\^[[8;11H\^[[m\^[[1;1H\^=
[[6
;11H\^[[m\^[[7m\^[[m\^[[7;11H\^[[m\^[[8;11H\^[[m\^[[1;1H\^[[m\^[[H\^[[Jav=
ail
memory =3D 1037377536 (1013064K bytes)
Preloaded elf kernel "kernel" at 0xc0829000.
Preloaded mfs_root "/mfsroot" at 0xc0829084.
Warning: Pentium 4 CPU: PSE disabled
Pentium Pro MTRR support enabled
md0: Preloaded image </mfsroot> 4423680 bytes at 0xc03ef3d4
md1: Malloc disk
Using $PIR table, 10 entries at 0xc00f7b10
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
pcib2: <PCI to PCI bridge (vendor=3D1039 device=3D0001)> at device 1.0 =
on pci0
pci1: <PCI bus> on pcib2
pci1: <NVidia model 0281 graphics accelerator> at 0.0 irq 11
isab0: <SiS 85c503 PCI-ISA bridge> at device 2.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <SiS 5591 ATA33 controller> port 0xff00-0xff0f at device 2.5 on
pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pci0: <unknown card> (vendor=3D0x1039, dev=3D0x7012) at 2.7 irq 10
ohci0: <SiS 5571 USB controller> mem 0xdfffd000-0xdfffdfff irq 10 at =
device
3.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <SiS 5571 USB controller> on ohci0
usb0: USB revision 1.0
uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
uhub1: Texas Instruments TUSB2046 hub, class 9/0, rev 1.10/1.25, addr 2
uhub1: 4 ports with 4 removable, bus powered
ohci1: <SiS 5571 USB controller> mem 0xdfffe000-0xdfffefff irq 11 at =
device
3.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <SiS 5571 USB controller> on ohci1
usb1: USB revision 1.0
uhub2: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 3 ports with 3 removable, self powered
pci0: <USB controller> at 3.3 irq 3
sis0: <SiS 900 10/100BaseTX> port 0xd000-0xd0ff mem =
0xdfffc000-0xdfffcfff
irq 10 at device 4.0 on pci0
sis0: Ethernet address: 00:e0:18:f7:99:7a
miibus0: <MII bus> on sis0
rlphy0: <RTL8201L 10/100 media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pci0: <unknown card> (vendor=3D0x1102, dev=3D0x0002) at 10.0 irq 10
pci0: <unknown card> (vendor=3D0x1102, dev=3D0x7002) at 10.1
ohci2: <NEC uPD 9210 USB controller> mem 0xdfff9000-0xdfff9fff irq 10 at
device 13.0 on pci0
usb2: OHCI version 1.0
usb2: <NEC uPD 9210 USB controller> on ohci2
usb2: USB revision 1.0
uhub3: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 3 ports with 3 removable, self powered
ohci3: <NEC uPD 9210 USB controller> mem 0xdfffa000-0xdfffafff irq 10 at
device 13.1 on pci0
usb3: OHCI version 1.0
usb3: <NEC uPD 9210 USB controller> on ohci3
usb3: USB revision 1.0
uhub4: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
pci0: <USB controller> at 13.2 irq 10
pci0: <unknown card> (vendor=3D0x1106, dev=3D0x3044) at 14.0 irq 10
pcib1: <SiS 5591 host to AGP bridge> on motherboard
pci2: <PCI bus> on pcib1
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on =
isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on =
isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=3D0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
plip0: <PLIP network interface> on ppbus0
ad0: 78533MB <HDS728080PLAT20> [159560/16/63] at ata0-master WDMA2
ad2: 114473MB <ST3120023A> [232581/16/63] at ata1-master WDMA2
acd0: DVD-R <DVD-RW IDE1008> at ata1-slave PIO4
Mounting root from ufs:/dev/md0c
fwohci0: <VIA VT6306> port 0xc800-0xc87f mem 0xdfffb000-0xdfffb7ff irq =
10 at
device 14.0 on pci0
fwohci0: OHCI version 1.0 (ROM=3D1)
fwohci0: No. of Isochronous channel is 8.
fwohci0: EUI64 00:11:06:00:00:00:31:cc
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwohci0: Initiate bus reset
fwohci0: node_id=3D0xc800ffc0, gen=3D1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <=3D 0, cable IRM =3D 0 (me)
firewire0: bus manager 0 (me)
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:11:06:00:31:cc
sbp0: <SBP-2/SCSI over FireWire> on firewire0
sio1: configured irq 3 not in bitmap of probed irqs 0
Waiting (max 60 seconds) for system process `vnlru' to stop...stopped
Waiting (max 60 seconds) for system process `bufdaemon' to =
stop...stopped
Waiting (max 60 seconds) for system process `syncer' to stop...stopped

syncing disks...=20
done
Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD 4.10-RELEASE #0: Tue May 25 22:47:12 GMT 2004
    root@perseus.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz (2404.11-MHz 686-class CPU)
  Origin =3D "GenuineIntel"  Id =3D 0xf27  Stepping =3D 7
=20
Features=3D0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PG=
E,MCA
,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory  =3D 1073676288 (1048512K bytes)
avail memory =3D 1039618048 (1015252K bytes)
Preloaded elf kernel "kernel" at 0xc0551000.
Warning: Pentium 4 CPU: PSE disabled
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 10 entries at 0xc00f7b10
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <SIS Generic host to PCI bridge> mem 0xe0000000-0xe3ffffff at =
device
0.0 on pci0
pcib2: <PCI to PCI bridge (vendor=3D1039 device=3D0001)> at device 1.0 =
on pci0
pci1: <PCI bus> on pcib2
pci1: <NVidia model 0281 graphics accelerator> at 0.0 irq 11
isab0: <SiS 85c503 PCI-ISA bridge> at device 2.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <SiS 5591 ATA33 controller> port 0xff00-0xff0f at device 2.5 on
pci0
ata0: at 0x1f0 irq 14 on atapci0
ata1: at 0x170 irq 15 on atapci0
pci0: <unknown card> (vendor=3D0x1039, dev=3D0x7012) at 2.7 irq 10
ohci0: <SiS 5571 USB controller> mem 0xdfffd000-0xdfffdfff irq 10 at =
device
3.0 on pci0
usb0: OHCI version 1.0, legacy support
usb0: SMM does not respond, resetting
usb0: <SiS 5571 USB controller> on ohci0
usb0: USB revision 1.0
uhub0: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 3 ports with 3 removable, self powered
uhub1: Texas Instruments TUSB2046 hub, class 9/0, rev 1.10/1.25, addr 2
uhub1: 4 ports with 4 removable, bus powered
ulpt0: hp deskjet 3600, rev 2.00/1.00, addr 3, iclass 7/1
ulpt0: using bi-directional mode
ohci1: <SiS 5571 USB controller> mem 0xdfffe000-0xdfffefff irq 11 at =
device
3.1 on pci0
usb1: OHCI version 1.0, legacy support
usb1: SMM does not respond, resetting
usb1: <SiS 5571 USB controller> on ohci1
usb1: USB revision 1.0
uhub2: SiS OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 3 ports with 3 removable, self powered
pci0: <USB controller> at 3.3 irq 3
sis0: <SiS 900 10/100BaseTX> port 0xd000-0xd0ff mem =
0xdfffc000-0xdfffcfff
irq 10 at device 4.0 on pci0
sis0: Ethernet address: 00:e0:18:f7:99:7a
miibus0: <MII bus> on sis0
rlphy0: <RTL8201L 10/100 media interface> on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pci0: <unknown card> (vendor=3D0x1102, dev=3D0x0002) at 10.0 irq 10
pci0: <unknown card> (vendor=3D0x1102, dev=3D0x7002) at 10.1
ohci2: <NEC uPD 9210 USB controller> mem 0xdfff9000-0xdfff9fff irq 10 at
device 13.0 on pci0
usb2: OHCI version 1.0
usb2: <NEC uPD 9210 USB controller> on ohci2
usb2: USB revision 1.0
uhub3: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 3 ports with 3 removable, self powered
uhid0: Microsoft\M-. Microsoft\M-. SideWinder\M-. Game Pad USB, rev
2.00/1.06, addr 2, iclass 3/0
ohci3: <NEC uPD 9210 USB controller> mem 0xdfffa000-0xdfffafff irq 10 at
device 13.1 on pci0
usb3: OHCI version 1.0
usb3: <NEC uPD 9210 USB controller> on ohci3
usb3: USB revision 1.0
uhub4: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub4: 2 ports with 2 removable, self powered
ugen0: vendor 0x0c45 USB camera, rev 1.10/1.00, addr 2
ugen1: Sigmatel Inc IrDA/USB Bridge, rev 1.10/0.08, addr 3
pci0: <USB controller> at 13.2 irq 10
fwohci0: <VIA VT6306> port 0xc800-0xc87f mem 0xdfffb000-0xdfffb7ff irq =
10 at
device 14.0 on pci0
fwohci0: OHCI version 1.0 (ROM=3D1)
fwohci0: No. of Isochronous channel is 8.
fwohci0: EUI64 00:11:06:00:00:00:31:cc
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 02:11:06:00:31:cc
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=3D0xc800ffc0, gen=3D1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <=3D 0, cable IRM =3D 0 (me)
firewire0: bus manager 0 (me)
pcib1: <SiS 5591 host to AGP bridge> on motherboard
pci2: <PCI bus> on pcib1
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on =
isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on =
isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=3D0x300>
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
ad0: 78533MB <HDS728080PLAT20> [159560/16/63] at ata0-master WDMA2
ad2: 114473MB <ST3120023A> [232581/16/63] at ata1-master WDMA2
acd0: DVD-R <DVD-RW IDE1008> at ata1-slave PIO4
Mounting root from ufs:/dev/ad0s1a



---
craig@small-pla.net
=20



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001c4d3af$0dd69240$6500a8c0>