Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 29 Jan 2007 11:57:40 -0800
From:      David Benfell <benfell@parts-unknown.org>
To:        freebsd-questions@freebsd.org
Subject:   Re: conflict between gimp-print and gutenprint
Message-ID:  <20070129195740.GA73759@parts-unknown.org>
In-Reply-To: <20070129173944.GC39489@slackbox.xs4all.nl>
References:  <20070129074438.GA15883@parts-unknown.org> <20070129173944.GC39489@slackbox.xs4all.nl>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help

--nFreZHaLTZJo0R7j
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Mon, 29 Jan 2007 18:39:44 +0100, Roland Smith wrote:
> On Sun, Jan 28, 2007 at 11:44:38PM -0800, David Benfell wrote:
> > Hello all,
> >=20
> > I am running FreeBSD 6.2 with CUPS and a printer--specifically an HP Co=
lor
> > LaserJet 5500-DN--that only seems to want to print with the Gutenprint =
port
> > installed.
> >=20
> > Even with the Gutenprint port installed, I had to copy the PPD file over
> > from a Linux laptop to get color working.
>=20
> You have to install the PPD file into CUPS. This can be done via
> administration/Add Printer or Printers/Modify Printer. I used the
> lpadmin app to add the ppd file:
>=20
> /usr/local/sbin/lpadmin -E -p clj2550 -v parallel:/dev/lpt0 -P clj2550.ppd
>=20
The -E option didn't work for me:

earth# /usr/local/sbin/lpadmin -E -p home -v socket://192.168.18.20 -P /usr=
/local/share/cups/model/custom/hp_color_LaserJet_5500.ppd=20
lpadmin: Unable to connect to server: Bad file descriptor

Omitting it worked, but I had to go through a cycle of enabling the printer
before it claimed it accepted a request to print a test page.

The man page for lpadmin claims both that the -E option forces encryption
to the server and enables the printer.

But even after all this, the test page still didn't actually print.  The
printer just sits there blissfully unaware that it is supposed to be printi=
ng
something.

> > Then I decided to install the Gimp.  The Gimp entails gimp-print which
> > conflicts with Gutenprint.  So I uninstalled Gutenprint.  And now I can=
't
> > get anything to print.
>=20
> In the GIMP, set up the printer as PostScript level 2, and also provide
> the PPD file.
>=20
> Works fine with my 2550L.
>=20

I'll have to try this after I can even get the printer to print under any
application at all.

Thanks!


--=20
David Benfell, LCP
benfell@parts-unknown.org
---
Resume available at http://www.parts-unknown.org/
NOTE: I sign all messages with GnuPG (0DD1D1E3).

--nFreZHaLTZJo0R7j
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (FreeBSD)

iD8DBQFFvlG0Ud+dMw3R0eMRAnxPAJ41dhuNiTmH9uef6VxzU3g8b4hvYwCfTr5d
VVfzIH09fkCXzadrnCmL7Ko=
=shgC
-----END PGP SIGNATURE-----

--nFreZHaLTZJo0R7j--



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20070129195740.GA73759>