Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 23 Sep 2014 16:44:26 +1000
From:      Ruben Schade <newsgroups@rubenschade.com>
To:        freebsd-questions@freebsd.org
Subject:   pkg must be version 1.3.8 or greater
Message-ID:  <lvr4sc$9f6$1@ger.gmane.org>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi everyone,

Running FreeBSD amd64 10.0-RELEAESE-p9. Installed everything from pkg, 
very nice system.

Prefer building nginx from ports, so portsnapped the latest tree and did 
the usual:

 > # cd /usr/ports/www/nginx
 > # make install clean

Got the following error:

===>  nginx-1.6.2,2 pkg(8) must be version 1.3.8 or greater, but you 
have 1.3.7. You must upgrade pkg(8) first.

Running pkg update however:

 > FreeBSD repository is up-to-date.
 > All repositories are up-to-date.

And pkg upgrade:

 > Updating FreeBSD repository catalogue...
 > FreeBSD repository is up-to-date.
 > All repositories are up-to-date.
 > Checking for upgrades (1 candidates): 100%
 > Checking integrity... done (0 conflicting)
 > Your packages are up to date.

Fairly new to pkgng, could that "1 candidates" line be the updated pkg I 
need in waiting?

Thanks,
Ruben

-- 
Ruben Schade
VM chap in s/Singapore/Sydney/
Site: http://rubenschade.com/
Blog: http://rubenerd.com/




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?lvr4sc$9f6$1>