Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 24 Jan 2009 08:49:43 -0500
From:      Lowell Gilbert <freebsd-questions-local@be-well.ilk.org>
To:        jimmiejaz@gmail.com
Cc:        freebsd-questions@freebsd.org, freebsd-ports@freebsd.org
Subject:   Re: x11-toolkits/linux-gtk2 problem/question.
Message-ID:  <44eiysvmo8.fsf@lowell-desk.lan>
In-Reply-To: <4979F1B1.4090808@gmail.com> (Jimmie James's message of "Fri\, 23 Jan 2009 11\:34\:57 -0500")
References:  <4979F1B1.4090808@gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Jimmie James <jimmiejaz@gmail.com> writes:

> While it looks like it install/runs fine (i.e, linux-flash9 works,
> skype works) the following error is show
> (process:47722): GLib-WARNING **: getpwuid_r(): failed due to unknown
> user id (0)
>
> Following this advice, all I could find,
> http://archive.netbsd.se/?ml=freebsd-emulation&a=2005-11&t=1506833
> The fix is, to tell /compat/linux/etc/nsswitch.conf to look at NIS too.
> Is UID 0 in your /etc/passwd? Can you try changeing
> /compat/linux/etc/nsswitch.conf to something like this:
>
> passwd:     files nisplus nis
> shadow:     files nisplus nis
> group:      files nisplus nis
>
> Uid 0 is in my /etc/passwd, there's no /compat/linux/etc/passwd., and
> changing /compat/linux/etc/nsswitch.conf to read the same doesn't fix
> the error message.
>
> Advice, suggestions?

Those setting for nsswitch.conf don't look right to me.
There should have been a message printed out when you installed one of
the linux_base ports, telling you how to configure it.
I think the fc4 version is the default these days; if that is what you
are using, the message is in the file
/usr/ports/emulators/linux_base-fc4/pkg-message


-- 
Lowell Gilbert, embedded/networking software engineer, Boston area
		http://be-well.ilk.org/~lowell/



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?44eiysvmo8.fsf>