Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 07 Feb 2012 20:44:54 +1000
From:      Da Rock <freebsd-questions@herveybayaustralia.com.au>
To:        freebsd-questions@freebsd.org
Subject:   Re: print/cups: CUPS-1.5.0 IPP protocoll issues -> no printing possible on IPP capable network printers
Message-ID:  <4F3100A6.3000207@herveybayaustralia.com.au>
In-Reply-To: <4F30E384.1080003@mail.zedat.fu-berlin.de>
References:  <4F30E384.1080003@mail.zedat.fu-berlin.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 02/07/12 18:40, O. Hartmann wrote:
> We use a bunch of HP and Xerox printers across our network, all capable
> of being accessed via network over IPP protocoall (so they claim).
>
> Printing worked for me  flawless on FreeBSD 8.2-STABLE, 9.0-CURRENT, now
> 9.0-STABLE on all boxes in question. Since updating cups to revision
> 1.5.0 (this is the most recent port version and I recently
> updated/recompiled the port and dependencies for all parts of CUPS
> either with CLANG and GCC 4.2.1), I get massive problems accessing
> printers on the network.
>
> Most HP printers accept a print job, but after accepting, CUPS reports
> printer has been stopped, can not obtain printer status. The job remains
> in the queue. Then I "restart" printer via CUPS, print job gets printed,
> but immediateley after printing has finished, the same problem occurs
> again: printer stopped - can not get printer status. Job remains still
> in the queue. Restarting printer via CUPS will start the game again,
> with the result of printing endless the same job, first in queue. I have
> to check whether the printer indeed has printed the job, delete the
> first queue entry, restart the printer again to get next job started ...
> and so on.
>
> A similar game on the Xerox printer facility. The printer reports
> "Unablae to get printer status", printing is here impossible!
>
> The XEROX printer is now attached to a Linux print server box running
> CUPS, an older CUPS on something like CentOS, I do not know what crap is
> running on the hardware. But: the printer works fine with older CUPS!
>
> Digging the internet revealed an issue reported in an Ubuntu forum/list,
> I already filed a PR (ports/164759). The Ubuntu report is about to be
> found here:
>
> https://bugs.launchpad.net/ubuntu/+source/cups/+bug/877958
>
> I was wondering if this "patch", whatever the Ubuntu fellows patched,
> couldn't be introduced to FreeBSD's CUPS port.
>
> Well, sorry about my impatience, but I'm floating like a dead man in the
> water, since I have to prepare printouts for a conference and printing
> is some kind of "neurological point" around here.
I know the feeling- try it with network (wifi particularly...) :)

What models out of curiosity? Have you tried other models?

As for the patch situation: try the maintainer of cups port, but that 
does require a wait of about 2 weeks (doesn't sound like you can wait) 
so perhaps try ports@. Or both cc'ing ports@...

HTH



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F3100A6.3000207>