Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 06 Oct 2011 18:55:50 +0100
From:      Paul Macdonald <paul@ifdnrg.com>
To:        Grant Peel <gpeel@thenetnow.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: FreeBSD 8.0 -> PHP 5.3.x
Message-ID:  <4E8DEBA6.4050902@ifdnrg.com>
In-Reply-To: <1A8828A857424EFDBBD748D48DF3512B@GRANTDESKTOP>
References:  <1A8828A857424EFDBBD748D48DF3512B@GRANTDESKTOP>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 06/10/2011 16:55, Grant Peel wrote:
> Hi all,
> Short of upgrading the OS, what is the safest way to upgrade a FreeBSD server to PHP 5.3.x from 5.2.11 ?
> I am assuming downloading the ports tarball and rebuilding and reinstalling will do it?
> Any advice, samples would be appreciated,
> -Grant
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe@freebsd.org"
>
It's not too traumatic an upgrade, and initially is as simple as you 
suggest,
remember  to uninstall extenstions via the meta port 
lang/php52-extensions (and reinstall desired extensions via 
lang/php5-extensions)

further suggestions, *
*copy the config make options from phpinfo() on 5.2 as it'll help you 
remember what you need for 5.3.
keep a copy of you php.ini obv also.
check http://uk3.php.net/migration53

you'll likely know but 5.3 is quite different from 5.2 so there's a few 
gotchas, such as  changes to log levels, no more register globals, you 
must explicitly use $_POST or $_GET
no more register_long_arrays, you cannot use $HTTP_POST_VARS
short tags are probably off  round about that version,

if i recall, there was some changes to a lot of my $_SESSION code so 
check any code that uses that, (but this could well have been my 
implementations.)



good luck
Paul.




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4E8DEBA6.4050902>