Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 23 Jan 2014 11:33:04 +0100
From:      Joar Jegleim <joar.jegleim@gmail.com>
To:        freebsd-questions <freebsd-questions@freebsd.org>
Subject:   Fwd: network config problem
Message-ID:  <CAFfb-hobEuTdx_v6ReKjKXJy0zFZpS83tMwMn_6V2Mj3Z5c_mg@mail.gmail.com>
In-Reply-To: <CAFfb-hrYHXjjFKNgV_jUoF8sirUc0JwBxa8yAs_f=P6+PHs2wA@mail.gmail.com>
References:  <CAFfb-hrYHXjjFKNgV_jUoF8sirUc0JwBxa8yAs_f=P6+PHs2wA@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
hmm, this might have been a bebcak.
I had put # REQUIRE: mountcritlocal iscsictl
in /etc/rc.d/zfs , trying to make zfs start after iscsi, since the zfs
pool are delivered through iscsi ...
Reverting that little hack made defautlrouter settings work from
rc.conf again (?)



---------- Forwarded message ----------
From: Joar Jegleim <joar.jegleim@gmail.com>
Date: 23 January 2014 09:31
Subject: network config problem
To: freebsd-questions <freebsd-questions@freebsd.org>


Hi list,

I'm looking at 10.0-RELEASE, on this particular server I've got 4
nic's, one of them uses vlan tagging.
When rebooting this box it doesn't setup the default route (?) .
Does anybody see what I don't in this /etc/rc.conf setup (?)

hostname="censored"
keymap="norwegian.iso.kbd"

# em0 in iscsi vlan
ifconfig_em0="inet 192.168.33.2 netmask 255.255.255.0 mtu 9000 media
1000baseTX mediaopt full-duplex"
# em1 in iscsi vlan
ifconfig_em1="inet 192.168.44.2 netmask 255.255.255.0 media 1000baseTX
mediaopt full-duplex"
# bce0 is plugged into 2 vlans
ifconfig_bce0="up" # gotta be up, or else vlan won't work
cloned_interfaces="vlan1 vlan2"
ifconfig_vlan1="inet 192.168.66.2 netmask 255.255.255.0 vlan 1 vlandev bce0"
ifconfig_vlan2="inet 192.168.77.2 netmask 255.255.255.0 vlan 2 vlandev bce0"
static_routes="net1 net2"
route_net1="-net 192.168.100.0/24 192.168.66.1"
route_net2="-net 192.168.150.0/24 192.168.66.1"

# bce0 is in vlan 3 and got defaultrouter
ifconfig_bce1="inet 192.168.200.2 netmask 255.255.255.0"
defaultrouter="192.168.200.1"

sshd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="NO"
munin_node_enable="YES"
nrpe2_enable="YES"

iscsid_enable="YES"
iscsictl_enable="YES"
iscsictl_flags="-Aa"
zfs_enable="YES"

exim_enable="YES"
sendmail_msp_queue_enable="NO"
sendmail_outbound_enable="NO"
sendmail_enable="NO"
sendmail_submit_enable="NO"
#nrpe_enable="YES"




--
----------------------
Joar Jegleim
Homepage: http://cosmicb.no
Linkedin: http://no.linkedin.com/in/joarjegleim
fb: http://www.facebook.com/joar.jegleim
AKA: CosmicB @Freenode

----------------------


-- 
----------------------
Joar Jegleim
Homepage: http://cosmicb.no
Linkedin: http://no.linkedin.com/in/joarjegleim
fb: http://www.facebook.com/joar.jegleim
AKA: CosmicB @Freenode

----------------------



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CAFfb-hobEuTdx_v6ReKjKXJy0zFZpS83tMwMn_6V2Mj3Z5c_mg>