Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 25 Jul 2018 08:16:12 -0400
From:      Robert Fitzpatrick <robert@webtent.org>
To:        FreeBSD <freebsd-questions@freebsd.org>
Subject:   Re: pkg update
Message-ID:  <5B586A0C.2000504@webtent.org>
In-Reply-To: <5B547FC9.7010107@webtent.org>
References:  <5B547FC9.7010107@webtent.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Robert Fitzpatrick via freebsd-questions wrote:
> Isn't 10.4 still alive? I plan to upgrade before October, but I'm seeing
> this now:
>
> root@data3:~ # uname -a
> FreeBSD data3.webtent.net 10.4-RELEASE-p9 FreeBSD 10.4-RELEASE-p9 #0:
> Tue May 8 07:05:01 UTC 2018
> root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC amd64
> root@data3:~ # pkg update
> /lib/libc.so.7: version FBSD_1.4 required by /usr/local/lib/libpkg.so.4
> not found
>
> Can someone suggest what I could do to correct this and update packages?
> I get the same whether trying to install a package or upgrade.
>
> Also, I keep receiving the same src updates but I don't have the src
> installed, how can I have freebsd-update not install src items as shown
> below? I do have some files in the /usr/src directory, perhaps I
> downloaded some src at some point in the past. Can't remember how they
> got there...
>

I was able to resolve the src messages by removing from the 
freebsd-update.conf file. I found this suggestion below to run 
pkg-static and perhaps identified the issue, why would I be running an 
old kernel and how can it be corrected?

root@data3:/usr/ports/ports-mgmt/pkg # pkg-static bootstrap -f
pkg(8) is already installed. Forcing reinstallation through pkg(7).
The package management tool is not yet installed on your system.
Do you want to fetch and install it now? [y/N]: y
Bootstrapping pkg from 
pkg+http://pkg.FreeBSD.org/freebsd:10:x86:64/latest, please wait...
Verifying signature with trusted certificate 
pkg.freebsd.org.2013102301... done
Installing pkg-1.10.5_1...
Newer FreeBSD version for package pkg:
To ignore this error set IGNORE_OSVERSION=yes
- package: 1004000
- running kernel: 1000510
Allow missmatch now?[Y/n]: n
package pkg is already installed, forced install
Extracting pkg-1.10.5_1: 100%
root@data3:/usr/ports/ports-mgmt/pkg # pkg update
/lib/libc.so.7: version FBSD_1.4 required by /usr/local/lib/libpkg.so.4 
not found

But all appears up to date:

root@data3:~ # freebsd-update fetch
Looking up update.FreeBSD.org mirrors... none found.
Fetching metadata signature for 10.4-RELEASE from update.FreeBSD.org... 
done.
Fetching metadata index... done.
Inspecting system... done.
Preparing to download files... done.

No updates needed to update system to 10.4-RELEASE-p9.

-- 
Robert




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5B586A0C.2000504>