Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 15 Oct 2013 09:35:01 +0100
From:      krad <kraduk@gmail.com>
To:        Monah Baki <monahbaki@gmail.com>
Cc:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: Tunnelling between Cisco and Freebsd
Message-ID:  <CALfReyfk0smiiGu0uiDAYKmU5cEjMtb2Dn==CSusoHk=mY3CsQ@mail.gmail.com>
In-Reply-To: <CALP3=x--XDhiMRhV5FfA=o47FpwQ+HLwtgg6vrvU8ta5agshAg@mail.gmail.com>
References:  <CALP3=x--XDhiMRhV5FfA=o47FpwQ+HLwtgg6vrvU8ta5agshAg@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
check the tunnel status as when i create on by default its not up

# ifconfig gre0
gre0: flags=9010<POINTOPOINT,LINK0,MULTICAST> metric 0 mtu 1476
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>


to fix

# ifconfig gre0 up
# ifconfig gre0
gre0: flags=9011<UP,POINTOPOINT,LINK0,MULTICAST> metric 0 mtu 1476
        inet6 fe80::a00:27ff:fe7d:7332%gre0 prefixlen 64 scopeid 0x6
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>


If you still have issues, you may need to specify the public ip on the
tunnel config. I seem to remember having to do this years ago with some gif
tunnels, but it may well be wrong now, maybe someone else can comment on
this

 eg

ifconfig gre0 tunnel 107.48.4.129 187.255.253.1

You might have to bind the public ip to your loopback to make this work.



On 13 October 2013 21:25, Monah Baki <monahbaki@gmail.com> wrote:

> Hi all,
>
> I am running FreeBSD 9.2. The FreeBSD server in on a private IP,
> 192.168.1.6. I have only one public IP and that's on my verizon firewall
> configured to port forward to my FreeBSD server.
>
> I do not control the Cisco device, but here is the config that was sent to
> me:
>
>
>
> interface Tunnel10
> ip address 10.1.1.1 255.255.255.252
> tunnel source GigabitEthernet0/0/2.1 (187.255.253.1)
> tunnel destination 107.48.4.129
>
> Here is what I did on my FreeBSD:
> ifconfig gre0 create
> ifconfig gre0 10.1.1.2 10.1.1.1 netmask 255.255.255.252
> ifconfig gre0 tunnel 192.168.1.6 187.255.253.1
>
>
> Now I can ping 10.1.1.1 (his end)
>
> But when I try to add a static route for his subnets via his tunnel IP, it
> fails
>
>
> root@devsrvr:/root # route add -net
> 187.255.252.0/22<http://197.255.252.0/22>10.1.1.1
> route: writing to routing socket: Network is unreachable
> add net 187.255.252.0 <http://197.255.252.0>: gateway 10.1.1.1: Network is
> unreachable
>
>
> Am I missing anything? It's my first time configuring a Tunnel.
>
>
> Thanks
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "
> freebsd-questions-unsubscribe@freebsd.org"
>



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CALfReyfk0smiiGu0uiDAYKmU5cEjMtb2Dn==CSusoHk=mY3CsQ>