Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 28 Dec 2013 08:59:27 +0800
From:      Erich Dollansky <erichsfreebsdlist@alogt.com>
To:        Lokadamus <lokadamus@gmx.de>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Probs with FreeBSD 10- Beta/ RC and Xorg
Message-ID:  <20131228085927.547ebae3@X220.alogt.com>
In-Reply-To: <52BE044F.6090800@gmx.de>
References:  <52BDC486.1060901@gmx.de> <20131228061414.2bc6aef3@X220.alogt.com> <52BE044F.6090800@gmx.de>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi,

On Fri, 27 Dec 2013 23:50:55 +0100
Lokadamus <lokadamus@gmx.de> wrote:

> Am 27.12.2013 23:14, schrieb Erich Dollansky:
> >
> > On Fri, 27 Dec 2013 19:18:46 +0100
> > Lokadamus <lokadamus@gmx.de> wrote:
> >
> >> I've made a clean install with FreeBSD 10.0-Beta1, updatet it to
> >> Beta2 and run it some weeks.
> >> Last week i see that RC2 was out and i made an upgrade.
> >> After that, i can't start xorg.
> >> For my graphiccard Intel i945GM i get the errormessage (see
> >> attachment Xorg.0.log-Beta2):
> >> EE) intel(0): Couldn't allocate video memory
> >>
> >> So i made a new installation with Beta1, install xorg, put hald and
> >> dbus in rc.conf and can't use
> >> mouse or keyboard.
> >> I see that hald isn't running.
> >> Its missing __bsd_iconvs as a dependency from libglib2.0.so
> >>
> >> Someone an idea what i can do?
> > I also did a fresh Install with BETA1 but installed the ports from
> > source and did not have problems. But I installed hal by hand as it
> > was not pulled in (if I remember right).
> >
> > I suggest an upgrade to RC3 via sources and a manual install of the
> > ports required.
> Compile xorg from ports needs 2 days to compile on my old P4- 3GHz.
> This is not an Option. :(

use the current binary with VESA and start the compile. You can work
then. Do not forget to start the compile with nice.

> >> I think, i will install FreeBSD 9.2
> > You could face the same problem.
> Only when xorg is updated to the same version as in FreeBSD 10 - RC2
> or higher.

Ports are not related to OS-versions. So, if you do not have the
original installation CD, it will be updated. But, you should be able
to download the RELEASE version of 9.2 which should have an older
version running.

You might get another opinion here which works for you.

Erich



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20131228085927.547ebae3>