Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 15 Jul 2017 01:11:04 +0200
From:      Jan Beich <jbeich@FreeBSD.org>
To:        Steven Nikkel <steven_nikkel@ertyu.org>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: OpenCL Issues
Message-ID:  <o9sm-hawn-wny@FreeBSD.org>
References:  <b18982c9-54ea-69c2-13d3-b507617cff60@ertyu.org> <y3rr-kvpx-wny@FreeBSD.org> <1b3fafb4-1f41-1ef0-dce5-3c97ccb39570@ertyu.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Steven Nikkel <steven_nikkel@ertyu.org> writes:

> On 2017-07-14 8:13 AM, Jan Beich wrote:
>> Steven Nikkel <steven_nikkel@ertyu.org> writes:
>>
>> See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=217635
>>
>
> Thanks, work around from the bug report solves my issue with beignet
> and I can successfully use OpenCL on that host.
            ^^^^^^^^^^^

Awesome! I'd like to update the port to a snapshot to pick up the fix in
question upstream, LLVM 4.0 support, more optimizations and catch
regressions early. Can you give it a try?

https://reviews.freebsd.org/D11377 (see Download Raw Diff)

> #0  0x0000000802d25075 in hwloc_topology_set_userdata_import_callback ()
>    from /usr/local/lib/libhwloc.so.5
> #1  0x0000000802d24f2d in hwloc_topology_set_userdata_import_callback ()
>    from /usr/local/lib/libhwloc.so.5
> #2  0x0000000802d24a77 in hwloc_topology_set_userdata_import_callback ()
>    from /usr/local/lib/libhwloc.so.5
> #3  0x0000000802d0b95b in hwloc_topology_load ()
>    from /usr/local/lib/libhwloc.so.5
> #4  0x0000000801722913 in pocl_cpuinfo_detect_compute_unit_count ()
>    from /usr/local/lib/libpocl.so.1.7.0

Probably https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219562
I haven't investigated it myself.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?o9sm-hawn-wny>