Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 17 Aug 2012 13:51:07 -0600
From:      Gary Aitken <freebsd@dreamchaser.org>
To:        freebsd-questions@freebsd.org, Matthew Seaman <matthew@freebsd.org>
Subject:   Re: 9.0 release hang in quiescent X
Message-ID:  <502EA0AB.9050708@dreamchaser.org>
In-Reply-To: <502C8D88.9040901@FreeBSD.org>
References:  <502C7AFB.2020303@dreamchaser.org> <502C8D88.9040901@FreeBSD.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 08/16/12 00:04, Matthew Seaman wrote:
> On 16/08/2012 05:45, Gary Aitken wrote:
...
>> Running 9.0 release on an amd 64 box, standard kernel, 16GB, SSD (/,
>> /usr, /var, /tmp) + HDDs, visiontek 900331 graphics card (ati radeon
>> hd5550).
>>
>> As long as I am using the system, things seem to be fine.  However,
>> when I leave the system idle for an extended period of time (e.g.
>> overnight, out for the day, etc.), it often refuses to return from
>> whatever state it is in.  The screen is blank and in standby for
>> power saving, and <ctl><alt> Fn won't get me a console prompt.  The
>> only way I know to recover is to power off and reboot.
...
>> Can someone suggest a good way to proceed to figure out what's going
>> on?
> 
> Can you get network access to the machine when it gets into this state?

I enabled remote logins and when the system hangs, I can neither log in nor ping it.  I can do both of those prior to a hang.

> If you can't, that suggests the OS is hanging or crashing, possibly in
> response to going into some sort of power-saving mode.
> 
> As to working out what the underlying cause of the problem is: that's
> harder.  I'd try experimenting with the power saving settings for your
> graphics display.  If you can turn them off as a test, and the machine
> then survives for an extended period of idleness, you'll have gone a
> long way towards isolating the problem.

My display, a NEC multisync LCD 1970NX, has a menu item for "Off Timer" but it is set to "off"  As far as I can tell there are no other power saving options on the display itself.

Could this be related to the sync rates?  I'm using whatever X.org and the drivers decided to come up with, which is 63.9kHz H, 59.9Hz V.

I have the following in rc.conf:
  powerd_enable="YES"     # Run powerd to lower our power usage.
  powerd_flags="-a hiadaptive -n hiadaptive -p 250"

I presume screen blanking is independent of cpu frequency rates, but it's not clear to me how the screen blanking is controlled.  How does screen blanking interact with BIOS?  My screen blanks, but it's not clear to me if it's BIOS or the os that's doing it.

man acpi indicates acpi should not be disabled:
  "Disabling all or part of ACPI on non-i386 platforms (i.e., platforms where ACPI support is mandatory) may result in a non-functional system."

On 08/16/12 00:06, Steve O'Hara-Smith wrote:
> 	Are you running any kind of screensaver ?
> 	Sometimes the OpenGL screen saver modules crash without proper
> hardware support. If you're running a screensaver try disabling it and just
> using display blanking.

I'm not running a screensaver, just blanking the screen.

Gary



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?502EA0AB.9050708>