Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 24 Mar 2009 14:17:52 +0700 (ICT)
From:      Olivier Nicole <on@cs.ait.ac.th>
To:        on@cs.ait.ac.th
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Installing 7.1 amd64 on Dell powerEdge 2950
Message-ID:  <200903240717.n2O7Hqui095050@banyan.cs.ait.ac.th>
In-Reply-To: <200903160456.n2G4uSFt009354@banyan.cs.ait.ac.th> (message from Olivier Nicole on Mon, 16 Mar 2009 11:56:28 +0700 (ICT))
References:  <200903160456.n2G4uSFt009354@banyan.cs.ait.ac.th>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Hi,

As a follow-up...

> I spent a couple of days trying to install FreeBSD 7.1 amd64 on a Dell
> PowerEdge 2950.
> 
> It won't finish booting properly from the installation CD:
> 
> with default boot, single user and verbose it stops at:
> fdc0: ...
> device_attach: fdc0 attach returned 6
> 
> with ACPI disabled and Safe mode it stops at:
> md0: Preloaded insge <boot/mfroot>...
> Trying to mount root from ufs /dev/md0
> 
> After it hangs, I waited about half hour and had to power down the
> machine.
> 
> Dell PowerEdge 1950 and 200 are not affected.
> 
> Any help?
I managed to install Release 6.4 amd64.

I cvsup'ed to RELENG 7.1 amd64.

I trimed down the kernel to keep only the devices needed by the
hardware.  It appreas that device sio is among the ones that hang the
load of GENERIC kernel.

"make kernel" would produce a bunch of lines like:
     kldxref: unknown metdata record 0 in file if_zyd.ko.symbols
     kldxref: unknown metdata record 0 in file if_zyd.ko.symbols
     kldxref: unknown metdata record 0 in file if_zyd.ko.symbols
but 7.1 would boot nevertheless.

After installing world on 7.1, the make kernel runs cleanly.

Best regards,

Olivier



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?200903240717.n2O7Hqui095050>