Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 14 May 2007 23:29:18 +0200
From:      Ladislav Jozsa <jozsa@volny.cz>
To:        freebsd-questions@freebsd.org
Subject:   3D acceleration within non-root account
Message-ID:  <4648D4AE.3090503@volny.cz>

Next in thread | Raw E-Mail | Index | Archive | Help
Hello there,

I'm trying to get 3D acceleration working on my ThinkPad R40 with ATI 
Radeon Mobility 7500 graphic card. I'm running FreeBSD 6.1 and I'm able 
to run 3D under root account, where glxinfo tells me the following:

# glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Radeon 20050528 AGP 4x TCL

But when I try the same under non-root account the result is:

$ glxinfo | grep render
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect

Thus 3D acceleration is not running. I've got loaded the following 
graphic drivers :

9     1 0xc4c21000 1c000    radeon.ko
10    1 0xc4c47000 e000     drm.ko

"dmesg | grep drm" gives me:

drm0: <ATI Radeon LW RV200 Mobility 7500 M7> port 0x3000-0x30ff mem 
0xe0000000-0xe7ffffff,0xc0100000-0xc010ffff irq 11 at device 0.0 on pci1
info: [drm] AGP at 0xd0000000 256MB
info: [drm] Initialized radeon 1.19.0 20050911

In Xorg configuration I  have also loaded following modules and DRI set 
properly:

Section "Module"
       Load  "dbe"
       Load  "dri"
       Load  "extmod"
       Load  "glx"
       Load  "record"
       Load  "xie"
       Load  "pex5"
       Load  "freetype"
       Load  "type1"
EndSection

Section "DRI"
       Mode 0666
EndSection

Does anyone know what else I need to run 3D under non-root account?

Many thanks,

Ladislav Jozsa










Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4648D4AE.3090503>