Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 4 Feb 2017 22:57:23 +0100
From:      Polytropon <freebsd@edvax.de>
To:        Roger Marquis <marquis@roble.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: Disappearing /dev/diskid/DISK*
Message-ID:  <20170204225723.0d29efcc.freebsd@edvax.de>
In-Reply-To: <1702041139150.62205@mx5.roble.com>
References:  <1702041139150.62205@mx5.roble.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 4 Feb 2017 11:42:07 -0800 (PST), Roger Marquis wrote:
> What would cause these entries be disappearing and reappearing, several
> days apart, on an 11.0-RELEASE-p6 system with ZFS root?

Other than the obvious (disks physically disconnecting),
I could imagine this has something to do with labels
(or in this case specifically, with disk serial numbers).
When a label is being used, for example to mount a
partition, the corresponding entry in the /dev subtree
will disappear, i. e. only those _not_ in use are present
there. Could it be some "automount"-related thing (when
you say it's happening more or less randomly)?

Maybe related:

https://www.freebsd.org/doc/handbook/geom-glabel.html

https://lists.freebsd.org/pipermail/freebsd-geom/2014-June/005921.html

http://bradleythughes.github.io/2015/05/06/booting-freebsd-zfs-raw-disks.html

https://forums.freebsd.org/threads/47671/


-- 
Polytropon
Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20170204225723.0d29efcc.freebsd>