Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 23 Jan 2014 14:47:21 +0100
From:      Tijl Coosemans <tijl@coosemans.org>
To:        Ross <basarevych@gmail.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: pkg: What am I doing wrong?
Message-ID:  <20140123144721.1e1e2946@kalimero.tijl.coosemans.org>
In-Reply-To: <20140123134744.000f7246@kalimero.tijl.coosemans.org>
References:  <CANmv3=wxsG6ENZifiri2Gv+34pSK35hrKv-NpOUHRGVjYJBkHQ@mail.gmail.com> <20140123134744.000f7246@kalimero.tijl.coosemans.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Thu, 23 Jan 2014 13:47:44 +0100 Tijl Coosemans wrote:
> On Thu, 23 Jan 2014 12:04:52 +0200 Ross wrote:
>> When I tried to install anything on a fresh FreeBSD 10 pkg failed. OK, I
>> googled the topic. Main repository is half empty at the moment for some
>> reason. I added another repo by creating /etc/pkg/release-0.conf:
>> 
>> release-0: {
>>   url: "pkg+http://pkg.FreeBSD.org/${ABI}/release/0",
>>   mirror_type: "srv",
>>   signature_type: "fingerprints",
>>   fingerprints: "/usr/share/keys/pkg",
>>   enabled: yes
>> }
>> 
>> So, now I have two repos: the main one and the release repo. Tried to
>> 
>> pkg install kde
>> 
>> After downloading the packages it failed because of conflicts. Apparently
>> it mixed main repo packages with the release repo and died. OK, run this
>> way:
>> 
>> pkg install -r release-0 kde
>> 
>> At last! Everything went well and now I have a KDE desktop. But what next?
>> I want to run "pkg upgrade" some time later and have all the packages
>> installed from the release repo to be updated to the latest version.
>> 
>> At the moment, after "pkg upgrade" I get a list of packages to be upgraded
>> and when I say "yes" pkg dies with errors like this (a lot of errors like
>> this):
>> 
>> pkg: WARNING: locally installed qt4-webkit-4.8.5 conflicts on
>> /usr/local/share/qt4/mkspecs/modules/qt_webkit_version.pri with:
>>         - qt4-webkit-4.8.5_1
>> 
>> So how do I upgrade? Am I doing something wrong?
> 
> There was a problem with the package builds last week.  Everything should
> be ok again now so you can remove the second repo.

Hmm, I looked at the wrong repo.  It's not ok yet, but it should be by
the end of the week or so.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?20140123144721.1e1e2946>