Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 24 May 2020 10:33:12 -0600
From:      Gary Aitken <freebsd@dreamchaser.org>
To:        FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   python version issue
Message-ID:  <449558a7-a457-48e5-a282-39e130f09853@dreamchaser.org>

Next in thread | Raw E-Mail | Index | Archive | Help
I'm trying to build a development version of a port (FreeCAD).  All
of my current ports were installed using packages, and the installed
versions of python are 2.7 and 3.7.

The Makefile for the standard freecad port (cad/freecad) specifies:
   USES= ... python:3.6 ...
   BUILD_DEPENDS=  ${PYTHON_PKGNAMEPREFIX}pyside2-tools>0:devel/pyside2-tools@${PY_FLAVOR}

It's my understanding that a 3.6 usage should be upward compatible
with a 3.7 version, so I changed the USES statement to python:3.7.
Unfortunately, the BUILD_DEPENDS causes problems:

make DISABLE_VULNERABILITIES=yes build
===>   FreeCAD-8.d821.f5.f depends on package: py37-pyside2-tools>0 - not found
===>  py37-pyside2-tools-5.12.1 Unknown flavor 'py37', possible flavors: py27
py36..

I see there is a devel/pyside2-tools, so I suspect I somehow need to
set some environment variables to get it to generate a
py37-pyside2-tools?  Why is py37 not an available flavor, with version
3.7 already installed?

Gary



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?449558a7-a457-48e5-a282-39e130f09853>