Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 11 Apr 2012 12:51:05 +0100
From:      "Dave B" <dave@g8kbv.demon.co.uk>
To:        freebsd-questions@freebsd.org
Subject:   FTP oddness, over SSH session.
Message-ID:  <4F857029.25481.F2968A@dave.g8kbv.demon.co.uk>

Next in thread | Raw E-Mail | Index | Archive | Help
FreeBSD FBSD.67MK181QZ 8.0-RELEASE FreeBSD 8.0-RELEASE #0:
Wed Apr 14 22:55:09 BST 2010     
root@FBSD.67MK181QZ:/usr/obj/usr/src/sys/PPSGENERIC  i386

Hi.

I have a small FreeBSD 8.0 system (above, yes I know, not current, but it 
works.) That is mainly used for timekeeping with an attached PPS equipped 
GPS.  No problems with that.

It also has a small web server (Hiawatha) FTP server and SSH portal, for 
my own use.

The FTP "server" is the built-in OS based ftpd implementation, and works 
well for all that I need.

Anyway...  I found a while ago, that I can tunnel connections into my 
home LAN via a SSH session to my FreeBSD box, from outside the LAN using 
PuTTY (on Windows XP) from wherever I am.  It's been a useful dodge for 
me to do that so as to VNC to other boxes that are there.   The needed 
SSH working port, is not the usual suspect, it's way up high, well away 
from script kiddies etc.

I just found however, that though I can reliably send a file to the FTP 
server and it get's saved just fine, that's not true when connecting this 
way using a SSH tunnel.

Over the SSH session, (using Passive Mode, with all needed ports 
forwarded, plus the FTP daemon's data port usage restricted to the same 
range as those tunneled.)  Though the FTP process appears to work OK, 
with no errors, the file sent to and deposited on the server ends up as 
name only, and zero bytes in length.

Oddly, I can successfully create a new folder on the FTP server over the 
SSH session using the FTP client, and that works just fine.

The FTP client I'm using, is the same FileZilla both times. (V3.1.0.1  I 
may go look for any updates, just in case.)

Downloading works fine regardless of how I connect, it's just uploading 
that's screwey.  I suspect (as usual) it's a rights issue, but even if I 
su - root after the initial SSH login, it changes nothing.

The FTP user is a different name from who I'm logged in as by SSH, is 
that the issue?    But what confuses me, is that it works from this same 
PC, if it's on the home LAN, using the same FTP user credentials.

I'm obviously lacking in my understanding of something, but what?

I may not get to see any replies for a day or three, as I've got to head 
off across country for work later, and it's not yet known if tonight's 
hotel even has WiFi, or if there is decent mobile coverage where I'm 
going.   (Out in the Wiltshire sticks. UK, and I'm stuck with Orange.)

Thanks in advance.

Dave B

-- Help for Hero's European Rally 2012 participant.
Please help by visiting:-
http://www.bmycharity.com/TeamSnowball
For any/all donations, all 100% goes to H4H.






Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4F857029.25481.F2968A>