Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 3 Sep 2017 22:31:32 -0600
From:      Adam Weinberger <adamw@adamw.org>
To:        koobs@FreeBSD.org
Cc:        Rene Ladan <rene@FreeBSD.org>, ports-committers@freebsd.org, svn-ports-all@freebsd.org, svn-ports-head@freebsd.org, "python@freebsd.org" <python@freebsd.org>
Subject:   Re: svn commit: r449195 - head/security/py-cryptography
Message-ID:  <9B4070BD-B841-40F8-9985-477457D9039D@adamw.org>
In-Reply-To: <96b4bb9f-dc46-ffea-bd49-a5949b5b7365@FreeBSD.org>
References:  <201709031028.v83AS09e027702@repo.freebsd.org> <96b4bb9f-dc46-ffea-bd49-a5949b5b7365@FreeBSD.org>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
> On 3 Sep, 2017, at 21:29, Kubilay Kocak <koobs@FreeBSD.org> wrote:
>=20
> On 9/3/17 8:28 PM, Rene Ladan wrote:
>> Author: rene
>> Date: Sun Sep  3 10:28:00 2017
>> New Revision: 449195
>> URL: https://svnweb.freebsd.org/changeset/ports/449195
>>=20
>> Log:
>>  security/py-cryptography: remove support for expired Python 3.3
>>=20
>> Modified:
>>  head/security/py-cryptography/Makefile
>>=20
>> Modified: head/security/py-cryptography/Makefile
>> =
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D
>> --- head/security/py-cryptography/Makefile	Sun Sep  3 10:12:26 2017	=
(r449194)
>> +++ head/security/py-cryptography/Makefile	Sun Sep  3 10:28:00 2017	=
(r449195)
>> @@ -35,8 +35,6 @@ RUN_DEPENDS+=3D	=
${PYTHON_PKGNAMEPREFIX}ipaddress>0:net/p
>>=20
>> .if ${PYTHON_REL} < 3300
>> RUN_DEPENDS+=3D	${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34
>> -.elif ${PYTHON_REL} < 3400
>> -RUN_DEPENDS+=3D	${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py3-enum34
>> .endif
>>=20
>> post-install:
>>=20
>=20
> Please revert this change:
>=20
> - It is *meant* to include all versions below 3.4, including 2.7
> - It is not necessary to delete when a python language port version is
> removed. The block still semantically and correctly declares the valid
> version dependency requirements from the upstream, independently from
> what the tree has at any point in time.
>=20
> Also, if you could, please ask/talk to python maintainers and/or =
python@
> with regard to port deprecation/deletions before committing. It is not
> always entirely obvious or explicit what is the correct thing to do is
> without fully understanding the versions support and semantics =
completely.

Python 2.7 needs py-enum34, not py3-enum34, and that block was left in. =
Unless I'm missing something, Ren=C3=A9's change should have no impact =
on python 2.7, no?

The argument against your second point is that sortof-but-not-really =
supporting expired versions of ports is a disservice to both porters and =
end-users, when it is unclear what is and isn't expected to work. The =
precedent these days is that expired ports are purged.

Your final point is well-taken, but I urge you to do the same. EXPIRED =
purges are tricky, and Ren=C3=A9 makes them happen every month. If ports =
marked for expiration need to be retained or handled specially, reach =
out to portmgr!

# Adam


--=20
Adam Weinberger
adamw@adamw.org
https://www.adamw.org





Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?9B4070BD-B841-40F8-9985-477457D9039D>