Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 16 Jul 2018 12:45:41 -0500
From:      Kyle Evans <kevans@freebsd.org>
To:        Matthias Fechner <idefix@fechner.net>
Cc:        FreeBSD Mailing List <freebsd-questions@freebsd.org>
Subject:   Re: 11.2 cannot boot with root on ZFS
Message-ID:  <CACNAnaGFRzET_RN7Xd4rETQ5qCwUVhyEpqZXAtj29QdAbGt2mA@mail.gmail.com>
In-Reply-To: <e49d702d-951c-47f3-0f8c-f26de2fc7613@fechner.net>
References:  <e49d702d-951c-47f3-0f8c-f26de2fc7613@fechner.net>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Fri, Jul 13, 2018 at 2:34 AM, Matthias Fechner <idefix@fechner.net> wrote:
> Dear all,
>
> I currently work with FreeBSD 11.1 booting from a ZFS mirror and having
> an additional raidz-1 pool:
>
>   pool: zroot
>  state: ONLINE
>   scan: scrub canceled on Mon Jul  2 22:12:31 2018
> config:
>
>         NAME            STATE     READ WRITE CKSUM
>         zroot           ONLINE       0     0     0
>           mirror-0      ONLINE       0     0     0
>             gpt/zroot0  ONLINE       0     0     0
>             gpt/zroot1  ONLINE       0     0     0
>
> errors: No known data errors
>
>   pool: zstorage
>  state: ONLINE
>   scan: scrub repaired 6.50G in 7h33m with 0 errors on Thu Jan 21
> 22:51:12 2016
> config:
>
>         NAME              STATE     READ WRITE CKSUM
>         zstorage          ONLINE       0     0     0
>           raidz1-0        ONLINE       0     0     0
>             gpt/storage0  ONLINE       0     0     0
>             gpt/storage1  ONLINE       0     0     0
>             gpt/storage2  ONLINE       0     0     0
>
> errors: No known data errors
>
> I tried to upgrade to 11.2 using freebsd-update:
> freebsd-update upgrade -r 11.2-RELEASE
> freebsd-update install
> reboot
>
> But FreeBSD 11.2 seems not to find the zfs pool anymore while booting.
> Giving the pool manually while it asks for does not help neither.

Hi,

To be clear- the kernel can't find the zfs pool, or one of the earlier
stages? Giving the pool manually meaning at a mountroot prompt, or
somewhere else?

> I checked the errata here:
> https://www.freebsd.org/releases/11.2R/errata.html
> and it seems that this error was discovered [2017-07-25].

This is for specifically for aarch64, but you've not specifically
mentioned it- you're on aarch64, right?

> Are there any actions planned to get that fixed?
> Currently I'm fixed to version 11.1 which runs out of support soon.
> Does anyone have an idea to work-around this problem?
>

I think we'll need a little more information about where and
specifically how it's failing for you to determine that. Others have
reported successful upgrades from 11.1 to 11.2 with root-on-ZFS
setups.

Thanks,

Kyle Evans



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?CACNAnaGFRzET_RN7Xd4rETQ5qCwUVhyEpqZXAtj29QdAbGt2mA>