Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 22 Sep 2009 15:22:40 -0400
From:      Lowell Gilbert <freebsd-questions-local@be-well.ilk.org>
To:        Scott Bennett <bennett@cs.niu.edu>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: /sys/modules/mii/nsgphy.c compilation errors
Message-ID:  <44hbuu6ayn.fsf@be-well.ilk.org>
In-Reply-To: <200909221111.n8MBBr07014335@mp.cs.niu.edu> (Scott Bennett's message of "Tue, 22 Sep 2009 06:11:53 -0500 (CDT)")
References:  <200909221111.n8MBBr07014335@mp.cs.niu.edu>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Scott Bennett <bennett@cs.niu.edu> writes:

>      An update committed since Friday appears to have broken mii/nsgphy.c
> in the kernel.  When I try to build a kernel now, I get the following errors
> during the compilations of mii/nsgphy.c.
>
> /usr/src/sys/modules/mii/../../dev/mii/nsgphy.c:104: error: 'MII_MODEL_NATSEMI_DP83865' undeclared here (not in a function)
> /usr/src/sys/modules/mii/../../dev/mii/nsgphy.c:104: error: 'MII_STR_NATSEMI_DP83865' undeclared here (not in a function)
> *** Error code 1
> 1 error
> *** Error code 2
> 1 error
> *** Error code 2
> 1 error
>
>      Having run cvsup just a few minutes ago and then having tried again to
> build a kernel, I see that the errors persist.  Is this something that someone
> is already fixing?  Or should I try to submit a PR?

You don't mention which branch you're on, but it sounds like it's
probably a local issue for your installation.  I built and installed
from the latest RELENG_7 today, and there are new bug reports on
RELENG_8 since Friday.  Those failing identifiers *are* present in the
correct sources; it looks like your miidevs.h isn't being regenerated
properly.  You *are* remembering to do a buildworld before a
buildkernel, right?

-- 
Lowell Gilbert, embedded/networking software engineer, Boston area
		http://be-well.ilk.org/~lowell/



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?44hbuu6ayn.fsf>