Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 16 May 2003 02:30:17 +0800
From:      "h0444lp6" <h0444lp6@student.hu-berlin.de>
To:        <freebsd-ports@freebsd.org>, <freebsd-questions@freebsd.org>
Subject:   apache/apache+ssl interchangeable with regard to mod_php4?
Message-ID:  <000001c31b10$1ade9f90$9bc3148d@kojo>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi all,

I am doing a little project which includes an Apache server secured
=A1=A7over=A1=A8 mod_ssl which serves pages generated using PHP-scripts =
(to
connect to MySQL), therefore I installd:

1) apache+mod_ssl-1.3.27+2.8.12.tgz
2) mod_php4-4.3.1.tgz

in that order from packages, only to find out that during mod_php4
install apache got "reinstalled" (apache-1.3.27_4.tgz).

My question is now, are "the apaches" in apache-1.3.27_4.tgz and
apache+ssl-1.3.27+2.8.12.tgz identical (the "_4" is confusing me)? To
say can I change the lines in php4-4.3.1's +CONTENTS file pointing to
apache-1.3.27_4

@pkgdep apache-1.3.27_4
@comment DEPORIGIN:www/apache13

to point to apache+ssl-1.3.27+2.8.12

@pkgdep apache+ssl-1.3.27+2.8.12
@comment DEPORIGIN:www/apache13-modssl

thus circumventing the "reinstallation". Or will I this way run into
trouble later on? I am running 4.8-Release.

Thanks in advance

Zheyu Shen






Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?000001c31b10$1ade9f90$9bc3148d>