Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 08 Aug 2013 07:43:08 -0600
From:      Gary Aitken <vagabond@blackfoot.net>
To:        felix <felix0930@me.com>
Cc:        freebsd-questions@freebsd.org
Subject:   Re: can't build virtualbox-ose
Message-ID:  <5203A06C.9040501@blackfoot.net>
In-Reply-To: <52037F85.3060106@me.com>
References:  <52037F85.3060106@me.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On 08/08/13 05:22, felix wrote:
> hi,all when i build the port, it shows the following messages.
> ===> Installing for gnutls-2.12.23_1
> ===>   Generating temporary packing list 
> ===>  Checking if security/gnutls already installed
> ===> gnutls-2.12.23_1 is already installed
> You may wish to ``make deinstall'' and install this port again
>  by ``make reinstall'' to
> upgrade it properly. If you really wish to overwrite the old port of
> security/gnutls without deleting it first, set the variable
> "FORCE_PKG_REGISTER" in your environment or the "make install"
> command line. *** [check-already-installed] Error code 1
...
> Stop in /usr/ports/emulators/virtualbox-ose.
> 
> I had run "portupgrade -fr security/gnutls", even though i run
> "portupgrade -a", the problem is still. any hints? thanks

I had this problem with a different port.
I think I got around it by cd'ing to the port directory and doing a make install.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5203A06C.9040501>