Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 30 Dec 1995 00:25:53 +0200 (SAT)
From:      Robert Nordier <rnordier@iafrica.com>
To:        questions@freebsd.org
Subject:   PPP glitches
Message-ID:  <199512292225.AAA00287@eac.iafrica.com>

Next in thread | Raw E-Mail | Index | Archive | Help
I set up user PPP a few days ago and have been having
a few problems.

Basically, everything works fine during the first
dial-in. But reconnecting later sometimes results in
one of two error messages:

     1)	SIOCAIFADDR: File exists
     2)	rtinit: wrong ifa (0xf0509d00) was (0xf0506980)

(the hex numbers vary)

I think the first error can be prevented by using
'route' to delete stuff left over from the previous
session, but the second error isn't as predictable.

One difficulty is that neither my IP address nor the
address of the ISP gateway is fixed. The gateway
IPs are 196.7.101.66 (usually) and 192.96.88.112
(sometimes). My own assigned IPs are all over the
place....

The main stuff changed to get PPP running was:

[/etc/hosts]
127.0.0.0	localhost
10.0.0.0	eac.iafrica.com	eac

[/etc/sysconfig]
ifconfig_tun0="inet eac.iafrica.com 10.0.0.1 netmask 0xffffff00"

[/etc/ppp/ppp.conf]
set ifaddr 0/0 0/0

Maybe I shouldn't complain: this all works fine if I 
keep rebooting before reconnecting to my ISP. But my
my guess is this _isn't_ as good as it gets....

If anyone has any light to throw on all of this, I'd 
appreciate it.

TIA




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?199512292225.AAA00287>