Skip site navigation (1)Skip section navigation (2)
Date:      Sun, 18 Feb 2007 03:21:29 -0800 (PST)
From:      Dino Vliet <dino_vliet@yahoo.com>
To:        freebsd-questions@freebsd.org
Subject:   X won start anymore
Message-ID:  <580671.74148.qm@web51109.mail.yahoo.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Hi folks,=0A=0Ahere I am again:-(=0AThis time, it is X which is causing tro=
ubles and I didn do anything. It worked for the last months without any pro=
blems and the last actions I did were:=0A=0A1) portsnap fetch update and th=
en a portupgrade -aRr=0A2) changed my BIOS to enable S.M.A.R.T. on my hardd=
isk=0A3) changed my BIOS to enable some sort of virus protection=0A=0AAfter=
 I rebooted I saw the following error at my console:=0A=0A..zouk gdm[873]: =
gdm_slave_xioerror_handler: Fatal X error - Restarting : 0=0AThis repeated =
3 times and it said something about Failed to start X server several times =
in a short time period; disabling display :0=0A=0AI was then trown at the c=
ommand line (Yippee:-)=0A=0ASo, I went to the /etc/X11/ directory and looke=
d at my xorg.conf file. Didn see anything strange in it (mind you, I haven =
changed it lately and it has been running for months without a problem)=0A=
=0AThen I did the startx command and saw this error message:=0A=0A...using =
config file: etc/X11/xorg.conf =0A(EE) No devices detected=0A=0AFatal serve=
r error:=0Ano screens found=0A=0AMy xorg.conf looks like this:=0ASection "S=
erverLayout"=0A=09Identifier     "X.org Configured"=0A=09Screen      0  "Sc=
reen0" 0 0=0A=09InputDevice    "Mouse0" "CorePointer"=0A=09InputDevice    "=
Keyboard0" "CoreKeyboard"=0AEndSection=0A=0ASection "Files"=0A=09RgbPath   =
   "/usr/X11R6/lib/X11/rgb"=0A=09ModulePath   "/usr/X11R6/lib/modules"=0A=
=09FontPath     "/usr/X11R6/lib/X11/fonts/misc/"=0A=09FontPath     "/usr/X1=
1R6/lib/X11/fonts/TTF/"=0A=09FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"=
=0A=09FontPath     "/usr/X11R6/lib/X11/fonts/CID/"=0A=09FontPath     "/usr/=
X11R6/lib/X11/fonts/75dpi/"=0A=09FontPath     "/usr/X11R6/lib/X11/fonts/100=
dpi/"=0A=09FontPath     "/usr/local/share/ghostscript/fonts/"=0AEndSection=
=0A=0ASection "Module"=0A=09Load  "extmod"=0A=09Load  "glx"=0A=09Load  "dri=
"=0A=09Load  "dbe"=0A=09Load  "record"=0A=09Load  "xtrap"=0A=09Load  "type1=
"=0A=09Load  "freetype"=0AEndSection=0A=0ASection "InputDevice"=0A=09Identi=
fier  "Keyboard0"=0A=09Driver      "kbd"=0AEndSection=0A=0ASection "InputDe=
vice"=0A=09Identifier  "Mouse0"=0A=09Driver      "mouse"=0A=09Option=09    =
"Protocol" "auto"=0A=09Option=09    "Device" "/dev/sysmouse"=0AEndSection=
=0A=0ASection "Monitor"=0A=09#DisplaySize=09  340   270=09# mm=0A=09Identif=
ier   "Monitor0"=0A=09VendorName   "HWP"=0A=09ModelName    "hp L1720"=0A ##=
# Uncomment if you don't want to default to DDC:=0A=09HorizSync    31.0 - 8=
0.0=0A=09VertRefresh  56.0 - 75.0=0A=09Option=09    "DPMS"=0AEndSection=0A=
=0ASection "Device"=0A        ### Available Driver options are:-=0A        =
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",=0A        ###=
 <string>: "String", <freq>: "<f> Hz/kHz/MHz"=0A        ### [arg]: arg opti=
onal=0A        #Option     "SWcursor"           =09# [<bool>]=0A        #Op=
tion     "HWcursor"           =09# [<bool>]=0A        #Option     "NoAccel"=
            =09# [<bool>]=0A        #Option     "ShadowFB"           =09# [=
<bool>]=0A        #Option     "UseFBDev"           =09# [<bool>]=0A        =
#Option     "Rotate"             =09# [<str>]=0A        #Option     "VideoK=
ey"           =09# <i>=0A        #Option     "FlatPanel"          =09# [<bo=
ol>]=0A        #Option     "FPDither"           =09# [<bool>]=0A        #Op=
tion     "CrtcNumber"         =09# <i>=0A        #Option     "FPScale"     =
       =09# [<bool>]=0A        #Option     "FPTweak"            =09# <i>=0A=
=09Identifier  "Card0"=0A=09Driver      "vesa"=0A=09#VendorName  "nVidia Co=
rporation"=0A=09BoardName   "Unknown Board"=0A=09BusID       "PCI:5:0:0"=0A=
EndSection=0A=0ASection "Screen"=0A=09Identifier "Screen0"=0A=09Device     =
"Card0"=0A=09Monitor    "Monitor0"=0A=09DefaultDepth 24=0A=09SubSection "Di=
splay"=0A=09=09Viewport   0 0=0A=09=09Depth     1=0A=09EndSubSection=0A=09S=
ubSection "Display"=0A=09=09Viewport   0 0=0A=09=09Depth     4=0A=09EndSubS=
ection=0A=09SubSection "Display"=0A=09=09Viewport   0 0=0A=09=09Depth     8=
=0A=09EndSubSection=0A=09SubSection "Display"=0A=09=09Viewport   0 0=0A=09=
=09Depth     15=0A=09EndSubSection=0A=09SubSection "Display"=0A=09=09Viewpo=
rt   0 0=0A=09=09Depth     16=0A=09EndSubSection=0A=09SubSection "Display"=
=0A=09=09Viewport   0 0=0A=09=09Depth     24=0A=09=09Modes =09"1280x1024" "=
1024x768"=0A=09EndSubSection=0AEndSection=0A=0Aand the var/log/Xorg.0.log f=
ile looks like:=0A=0AX Window System Version 6.9.0=0ARelease Date: 21 Decem=
ber 2005=0AX Protocol Version 11, Revision 0, Release 6.9=0ABuild Operating=
 System: FreeBSD 6.1 amd64 [ELF] =0ACurrent Operating System: FreeBSD zouk.=
tiscali.nl 6.1-RELEASE-p11 FreeBSD 6.1-RELEASE-p11 #12: Wed Jan 17 21:06:43=
 CET 2007     rgilaard@zouk.tiscali.nl:/usr/obj/usr/src/sys/MYKERNEL amd64=
=0ABuild Date: 29 January 2007=0A=09Before reporting problems, check http:/=
/wiki.X.Org=0A=09to make sure that you have the latest version.=0AModule Lo=
ader present=0AMarkers: (--) probed, (**) from config file, (=3D=3D) defaul=
t setting,=0A=09(++) from command line, (!!) notice, (II) informational,=0A=
=09(WW) warning, (EE) error, (NI) not implemented, (??) unknown.=0A(=3D=3D)=
 Log file: "/var/log/Xorg.0.log", Time: Sun Feb 18 11:59:56 2007=0A(=3D=3D)=
 Using config file: "/etc/X11/xorg.conf"=0A(=3D=3D) ServerLayout "X.org Con=
figured"=0A(**) |-->Screen "Screen0" (0)=0A(**) |   |-->Monitor "Monitor0"=
=0A(**) |   |-->Device "Card0"=0A(**) |-->Input Device "Mouse0"=0A(**) |-->=
Input Device "Keyboard0"=0A(WW) The directory "/usr/X11R6/lib/X11/fonts/CID=
/" does not exist.=0A=09Entry deleted from font path.=0A(**) FontPath set t=
o "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/TTF/,/usr/X11R6/=
lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fon=
ts/100dpi/,/usr/local/share/ghostscript/fonts/"=0A(**) RgbPath set to "/usr=
/X11R6/lib/X11/rgb"=0A(**) ModulePath set to "/usr/X11R6/lib/modules"=0A(II=
) Module ABI versions:=0A=09X.Org ANSI C Emulation: 0.2=0A=09X.Org Video Dr=
iver: 0.8=0A=09X.Org XInput driver : 0.5=0A=09X.Org Server Extension : 0.2=
=0A=09X.Org Font Renderer : 0.4=0A(II) Loader running on freebsd=0A(II) Loa=
dModule: "bitmap"=0A(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.so=
=0A(II) Module bitmap: vendor=3D"X.Org Foundation"=0A=09compiled for 6.9.0,=
 module version =3D 1.0.0=0A=09Module class: X.Org Font Renderer=0A=09ABI c=
lass: X.Org Font Renderer, version 0.4=0A(II) Loading font Bitmap=0A(II) Lo=
adModule: "pcidata"=0A(II) Loading /usr/X11R6/lib/modules/libpcidata.so=0A(=
II) Module pcidata: vendor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, mo=
dule version =3D 1.0.0=0A=09ABI class: X.Org Video Driver, version 0.8=0A(-=
-) Using syscons driver with X support (version 549739036674.0)=0A(++) usin=
g VT number 9=0A=0A(II) Addressable bus resource ranges are=0A=09[0] -1=090=
=090x00000000 - 0xffffffff (0x100000000) MX[B]=0A=09[1] -1=090=090x00000000=
 - 0xffffffff (0x100000000) IX[B]=0A(II) OS-reported resource ranges:=0A=09=
[0] -1=090=090xffffffff - 0xffffffff (0x1) MX[B]=0A=09[1] -1=090=090x000000=
00 - 0x00000000 (0x1) MX[B]=0A=09[2] -1=090=090x000c0000 - 0x000effff (0x30=
000) MX[B]=0A=09[3] -1=090=090xffffffff - 0xffffffff (0x1) IX[B]=0A=09[4] -=
1=090=090x00000000 - 0x000000ff (0x100) IX[B]=0A(II) OS-reported resource r=
anges after removing overlaps with PCI:=0A=09[0] -1=090=090xffffffff - 0xff=
ffffff (0x1) MX[B]=0A=09[1] -1=090=090x00000000 - 0x00000000 (0x1) MX[B]=0A=
=09[2] -1=090=090x000c0000 - 0x000effff (0x30000) MX[B]=0A=09[3] -1=090=090=
xffffffff - 0xffffffff (0x1) IX[B]=0A=09[4] -1=090=090x00000000 - 0x000000f=
f (0x100) IX[B]=0A(II) All system resource ranges:=0A=09[0] -1=090=090xffff=
ffff - 0xffffffff (0x1) MX[B]=0A=09[1] -1=090=090x00000000 - 0x00000000 (0x=
1) MX[B]=0A=09[2] -1=090=090x000c0000 - 0x000effff (0x30000) MX[B]=0A=09[3]=
 -1=090=090xffffffff - 0xffffffff (0x1) IX[B]=0A=09[4] -1=090=090x00000000 =
- 0x000000ff (0x100) IX[B]=0A(II) LoadModule: "extmod"=0A(II) Loading /usr/=
X11R6/lib/modules/extensions/libextmod.so=0A(II) Module extmod: vendor=3D"X=
.Org Foundation"=0A=09compiled for 6.9.0, module version =3D 1.0.0=0A=09Mod=
ule class: X.Org Server Extension=0A=09ABI class: X.Org Server Extension, v=
ersion 0.2=0A(II) Loading extension SHAPE=0A(II) Loading extension MIT-SUND=
RY-NONSTANDARD=0A(II) Loading extension BIG-REQUESTS=0A(II) Loading extensi=
on SYNC=0A(II) Loading extension MIT-SCREEN-SAVER=0A(II) Loading extension =
XC-MISC=0A(II) Loading extension XFree86-VidModeExtension=0A(II) Loading ex=
tension XFree86-Misc=0A(II) Loading extension XFree86-DGA=0A(II) Loading ex=
tension DPMS=0A(II) Loading extension TOG-CUP=0A(II) Loading extension Exte=
nded-Visual-Information=0A(II) Loading extension XVideo=0A(II) Loading exte=
nsion XVideo-MotionCompensation=0A(II) Loading extension X-Resource=0A(II) =
LoadModule: "glx"=0A(II) Loading /usr/X11R6/lib/modules/extensions/libglx.s=
o=0A(II) Module glx: vendor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, m=
odule version =3D 1.0.0=0A=09ABI class: X.Org Server Extension, version 0.2=
=0A(II) Loading sub module "GLcore"=0A(II) LoadModule: "GLcore"=0A(II) Load=
ing /usr/X11R6/lib/modules/extensions/libGLcore.so=0A(II) Module GLcore: ve=
ndor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, module version =3D 1.0.0=
=0A=09ABI class: X.Org Server Extension, version 0.2=0A(II) Loading extensi=
on GLX=0A(II) LoadModule: "dri"=0A(II) Loading /usr/X11R6/lib/modules/exten=
sions/libdri.so=0A(II) Module dri: vendor=3D"X.Org Foundation"=0A=09compile=
d for 6.9.0, module version =3D 1.0.0=0A=09ABI class: X.Org Server Extensio=
n, version 0.2=0A(II) Loading sub module "drm"=0A(II) LoadModule: "drm"=0A(=
II) Loading /usr/X11R6/lib/modules/freebsd/libdrm.so=0A(II) Module drm: ven=
dor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, module version =3D 1.0.0=
=0A=09ABI class: X.Org Server Extension, version 0.2=0A(II) Loading extensi=
on XFree86-DRI=0A(II) LoadModule: "dbe"=0A(II) Loading /usr/X11R6/lib/modul=
es/extensions/libdbe.so=0A(II) Module dbe: vendor=3D"X.Org Foundation"=0A=
=09compiled for 6.9.0, module version =3D 1.0.0=0A=09Module class: X.Org Se=
rver Extension=0A=09ABI class: X.Org Server Extension, version 0.2=0A(II) L=
oading extension DOUBLE-BUFFER=0A(II) LoadModule: "record"=0A(II) Loading /=
usr/X11R6/lib/modules/extensions/librecord.so=0A(II) Module record: vendor=
=3D"X.Org Foundation"=0A=09compiled for 6.9.0, module version =3D 1.13.0=0A=
=09Module class: X.Org Server Extension=0A=09ABI class: X.Org Server Extens=
ion, version 0.2=0A(II) Loading extension RECORD=0A(II) LoadModule: "xtrap"=
=0A(II) Loading /usr/X11R6/lib/modules/extensions/libxtrap.so=0A(II) Module=
 xtrap: vendor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, module version=
 =3D 1.0.0=0A=09Module class: X.Org Server Extension=0A=09ABI class: X.Org =
Server Extension, version 0.2=0A(II) Loading extension DEC-XTRAP=0A(II) Loa=
dModule: "type1"=0A(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.so=0A=
(II) Module type1: vendor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, mod=
ule version =3D 1.0.2=0A=09Module class: X.Org Font Renderer=0A=09ABI class=
: X.Org Font Renderer, version 0.4=0A(II) Loading font Type1=0A(II) Loading=
 font CID=0A(II) LoadModule: "freetype"=0A(II) Loading /usr/X11R6/lib/modul=
es/fonts/libfreetype.so=0A(II) Module freetype: vendor=3D"X.Org Foundation =
& the After X-TT Project"=0A=09compiled for 6.9.0, module version =3D 2.1.0=
=0A=09Module class: X.Org Font Renderer=0A=09ABI class: X.Org Font Renderer=
, version 0.4=0A(II) Loading font FreeType=0A(II) LoadModule: "vesa"=0A(II)=
 Loading /usr/X11R6/lib/modules/drivers/vesa_drv.so=0A(II) Module vesa: ven=
dor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, module version =3D 1.0.1=
=0A=09Module class: X.Org Video Driver=0A=09ABI class: X.Org Video Driver, =
version 0.8=0A(II) LoadModule: "mouse"=0A(II) Loading /usr/X11R6/lib/module=
s/input/mouse_drv.so=0A(II) Module mouse: vendor=3D"X.Org Foundation"=0A=09=
compiled for 6.9.0, module version =3D 1.0.3=0A=09Module class: X.Org XInpu=
t Driver=0A=09ABI class: X.Org XInput driver, version 0.5=0A(II) LoadModule=
: "kbd"=0A(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so=0A(II) Modul=
e kbd: vendor=3D"X.Org Foundation"=0A=09compiled for 6.9.0, module version =
=3D 1.0.1=0A=09Module class: X.Org XInput Driver=0A=09ABI class: X.Org XInp=
ut driver, version 0.5=0A(II) VESA: driver for VESA chipsets: vesa=0A(WW) x=
f86EnableIO: Failed to open /dev/io for extended I/O(EE) No devices detecte=
d.=0A=0AFatal server error:=0Ano screens found=0A=0APlease consult the The =
X.Org Foundation support =0A=09 at http://wiki.X.Org=0A for help. =0APlease=
 also check the log file at "/var/log/Xorg.0.log" for additional informatio=
n.=0A=0ADoes anyone have a clue?=0A=0AThanks in advanced for your help!!!=
=0A=0A=0A=0A =0A___________________________________________________________=
_________________________=0ANever miss an email again!=0AYahoo! Toolbar ale=
rts you the instant new Mail arrives.=0Ahttp://tools.search.yahoo.com/toolb=
ar/features/mail/



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?580671.74148.qm>