Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 5 Feb 1996 13:20:58 +1030 (CST)
From:      Michael Smith <msmith@atrad.adelaide.edu.au>
To:        acolyte@uoknor.edu (Eric Eiseman)
Cc:        freebsd-questions@FreeBSD.org
Subject:   Re: Kernel still won't ID internal modem on com2
Message-ID:  <199602050250.NAA05941@genesis.atrad.adelaide.edu.au>
In-Reply-To: <3115193d679a002@cliff.uoknor.edu> from "Eric Eiseman" at Feb 4, 96 02:38:22 pm

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Eric Eiseman stands accused of saying:
> 
> Well I tried to comment out part of the failure code in sio.c, but I still
> wasn't able to get my internal modem recognized by the system.  I'm still
> using 2.1.0-RELEASE....so do any of the newer packages seem to address this
> kind of problem (i.e. 2.1.0-Stable,Current or 2.2-Current)?

Let's guess, your modem doesn't have a 'real' 16550 on it, but instead one
of those _STUPID_ UART emulations.

In the sioproble() function, uncomment all the changes you made (that's
not the solution).  At each of the EXTRA DELAY comments, insert a line
reading DELAY(5000);

This may help your bogus modem to catch up.  The real solution is to sell
it to some Windows-using sucker and buy a real modem.

> Eric Eiseman

-- 
]] Mike Smith, Software Engineer        msmith@atrad.adelaide.edu.au    [[
]] Genesis Software                     genesis@atrad.adelaide.edu.au   [[
]] High-speed data acquisition and      (GSM mobile) 0411-222-496       [[
]] realtime instrument control          (ph/fax)  +61-8-267-3039        [[
]] "wherever you go, there you are" - Buckaroo Banzai                   [[



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?199602050250.NAA05941>