Skip site navigation (1)Skip section navigation (2)
Date:      Tue, 19 Jan 2010 22:15:21 +0100
From:      =?ISO-8859-1?Q?Morgan_Wesstr=F6m?= <freebsd-questions@pp.dyndns.biz>
To:        FreeBSD Questions <freebsd-questions@freebsd.org>
Subject:   Re: Missing all ttyv* device nodes after upgrade 7.0 -> 7.2
Message-ID:  <4B5620E9.6040902@pp.dyndns.biz>
In-Reply-To: <4B561A81.6010400@pp.dyndns.biz>
References:  <4B561717.9090309@pp.dyndns.biz> <4B561A81.6010400@pp.dyndns.biz>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Morgan Wesström wrote:
> Morgan Wesström wrote:
>> I obviously did something wrong somewhere but I can't figure out what.
>> All console device nodes /dev/ttyv0 - /dev/ttyvf are missing after I
>> upgraded a machine from 7.0 to 7.2. The serial console node /dev/ttyd0
>> is there though if that rings a bell. What controls the creation of the
>> console device nodes? Any hints on what I should check? I did deactivate
>> unneeded SCSI-drivers and the like in the GENERIC kernel but the tty
>> related stuff is still there, like:
>>
>> options         COMPAT_43TTY            # BSD 4.3 TTY compat
>> device          sc
>>
> 
> I'm also missing /dev/consolectl
> 

These dmesg lines are from another 7.2 machine and I am missing them
from the output of this newly upgraded machine:

sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0

Both devices are in the kernel. What could prevent them from binding?
/Morgan



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?4B5620E9.6040902>