Skip site navigation (1)Skip section navigation (2)
Date:      Wed, 21 Aug 1996 10:09:32 -0700 (PDT)
From:      Ken Marsh <durang@u.washington.edu>
To:        Gary Kline <kline@tera.com>
Cc:        questions@FreeBSD.org
Subject:   SB16 and kernel config
Message-ID:  <Pine.A32.3.92a.960821100129.169152A-100000@homer06.u.washington.edu>
In-Reply-To: <199608191749.KAA14356@athena.tera.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Mon, 19 Aug 1996, Gary Kline wrote:

	[SNIP]

> 	My soundcard is on irq 10 and to avoid the muddling with
> 	any conflicts, I have commented out these lines.  Replaced
> 	these with my SB. Sunday I attempted to rebuild my 2.1.5
> 	kernel without attention to detail, and because of the
> 	reorganization, things flopped.


One oddity about the soundcard deal that I ran into (and came to a dead
stop with), was that if you have soundblaster 16, you need the lines for
soundblaster, the lines for SB16, the line for the midi device, AND the
line for the Yamaha fm device. The docs aren't so clear on this point. My
sound configurations lines are as follows:

# a shot at soundblaster:
controller      snd0
device sb0 at isa? port 0x220 irq 5 drq 1 vector sbintr
options "SBC_IRQ=5"
device          sbxvi0  at isa? drq 5
device          sbmidi0 at isa? port 0x330
# Yamaha OPL-2/OPL-3 FM - for SB, SB Pro, SB16, PAS
device opl0     at isa? port 0x388
#Probing problems:  Since the SB16 uses the same IRQ and addresses for
#the different drivers, some of the snd dirvers will not be probed because
#the kernel thinks there is a conflict.  This can be worked-around by
#setting the ALLOW_CONFLICT_IOADDR or ALLOW_CONFLICT_IRQ options.

I still have problems with some sound, for example my cd-audio software,
xmcd gives me the dread "device not configured" error..

Ken Marsh




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?Pine.A32.3.92a.960821100129.169152A-100000>