Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 28 Dec 2013 08:30:22 -0700 (MST)
From:      Warren Block <wblock@wonkity.com>
To:        CeDeROM <cederom@tlen.pl>
Cc:        Lokadamus <lokadamus@gmx.de>, FreeBSD Questions Mailing List <freebsd-questions@freebsd.org>
Subject:   Re: Probs with FreeBSD 10- Beta/ RC and Xorg
Message-ID:  <alpine.BSF.2.00.1312280827180.41341@wonkity.com>
In-Reply-To: <CAFYkXjmBn4JNRcWntweACEP=xFeVvtr1UOH_=eO-cTHYFxxSpQ@mail.gmail.com>
References:  <52BDC486.1060901@gmx.de> <20131228061414.2bc6aef3@X220.alogt.com> <52BE044F.6090800@gmx.de> <CAFYkXjmBn4JNRcWntweACEP=xFeVvtr1UOH_=eO-cTHYFxxSpQ@mail.gmail.com>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
On Sat, 28 Dec 2013, CeDeROM wrote:

> On Fri, Dec 27, 2013 at 11:50 PM, Lokadamus <lokadamus@gmx.de> wrote:
>> Am 27.12.2013 23:14, schrieb Erich Dollansky:
>>> On Fri, 27 Dec 2013 19:18:46 +0100
>>> Lokadamus <lokadamus@gmx.de> wrote:
>>>> So i made a new installation with Beta1, install xorg, put hald and
>>>> dbus in rc.conf and can't use
>>>> mouse or keyboard.
>>>> I see that hald isn't running.
>>>> Its missing __bsd_iconvs as a dependency from libglib2.0.so
>
> To use input with no hald put this into your /etc/X11/xorg.conf:
>
> Section "ServerFlags"
>        Option "AllowEmptyInput" "False"
> EndSection
>
> Note that this option is exclusive with hald and it will cause
> problems when both are present :-)

It will cause problems much of the time regardless.  Please stop using 
AllowEmptyInput.  To prevent xorg-server from using hal, the correct 
entry is
   Option "AutoAddDevices" "Off"

http://www.wonkity.com/~wblock/docs/html/aei.html explains in more 
detail.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?alpine.BSF.2.00.1312280827180.41341>