Skip site navigation (1)Skip section navigation (2)
Date:      Thu, 06 Dec 2018 13:40:32 -0500
From:      Ernie Luzar <luzar722@gmail.com>
To:        FreeBSD current <freebsd-current@freebsd.org>,  "freebsd-jail@freebsd.org" <freebsd-jail@freebsd.org>, "freebsd-questions@freebsd.org" <freebsd-questions@freebsd.org>
Subject:   12.0-RC3 vnet jail with pf firewall/NAT not working
Message-ID:  <5C096D20.3040305@gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
Have gateway host, (ie; host that is connected directly to the public 
internet.) running a vnet jail that has pf firewall running inside of 
it. When I start the vnet jail I see a few dhclient tasks auto start for 
vge0 which is the interface added as member to the bridge. I take this 
to mean that the vnet jails external network is configured correctly.

Can not ping 8.8.8.8 from the vnet jails console. I can see the pf rules 
are loaded. But the pf log shows no traffic at all.

Think problem is with the nat rule syntax or the nat function of pf is 
non-functional. Can not reach the public internet using this nat rule

nat pass on epair2b inet from 10.0.20.10 to any -> xx.xx.xx.xx

10.0.20.10 is ip address assigned to the vnet jail
xx.xx.xx.xx is the ip address assigned to the host by the isp.

Also tried this with no joy

nat pass on epair2b inet from 10.0.20.10 to any ->  epair2b

Anyone been able to get pf NAT to work in a live vnet jail in this manner?



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?5C096D20.3040305>