Skip site navigation (1)Skip section navigation (2)
Date:      Mon, 2 Aug 2004 19:35:41 +0200
From:      "Daniel Eriksson" <daniel_k_eriksson@telia.com>
To:        "'Ville-Pertti Keinonen'" <will+freebsd-current@will.iki.fi>, <freebsd-current@freebsd.org>
Subject:   RE: ATA driver races with interrupts
Message-ID:  <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAAtrV5IQbrQUKQ3LWR5RFP/AEAAAAA@telia.com>
In-Reply-To: <410E74F7.1070000@will.iki.fi>

Next in thread | Previous in thread | Raw E-Mail | Index | Archive | Help
Ville-Pertti Keinonen wrote:

> Repeating the problem should be trivial with an unpatched 
> -current with 
> PREEMPTION enabled and hardware similar to mine - ASUS K8V 
> Deluxe, two 
> SATA disks on the VIA 6420:
> 
> ...
> atapci1: <VIA 6420 SATA150 controller> port 
> 0xd000-0xd0ff,0xd400-0xd40f,0xd800-0xd803,0xe000-0xe007,0xe400
> -0xe403,0xe800-0xe807 
> irq 20 at device 15.0 on pci0
> ata5: at 0xe800 on atapci1
> ata6: at 0xe000 on atapci1
> ...
> ad10: 152627MB <SAMSUNG SP1614C> [310101/16/63] at ata5-master SATA150
> ad12: 152627MB <SAMSUNG SP1614C> [310101/16/63] at ata6-master SATA150

This looks exactly like the problems I have had with similar hardware (ASUS
A7V600-X, a KT-600 based mobo with an on-board 6420 controller). With
preemption turned off it sort of worked, but with preemption turned on the
discs would lock up pretty quick just as you described it.

I have just applied the patch and will try it out later tonight once I get
everything recompiled. I'll let you know how it turns out.

/Daniel Eriksson




Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAA0VcX9IoJqUaXPS8MjT1PdsKAAAAQAAAAtrV5IQbrQUKQ3LWR5RFP/AEAAAAA>