Skip site navigation (1)Skip section navigation (2)
Date:      Fri, 12 Jun 2015 18:47:57 -0700
From:      George Hartzell <hartzell@alerce.com>
To:        FreeBSD Questions <questions@freebsd.org>
Subject:   FreeBSD 10.1, Mac Pro 2008, EFI, hangs at boot w/ "Start @0xfff...."
Message-ID:  <21883.35789.822027.413019@alacrity.local>

Next in thread | Raw E-Mail | Index | Archive | Help

I have a 2008 Mac Pro (NOT a MacBook) that's been happily running
FreeBSD for years via MBR partitioned disks.  When the Mac sees the
MBR partition it kicks in a bunch of bios emulation, which lets
freebsd run.

I've recently been inspired to try the EFI booting stuff.  It has the
attraction of enabling the two extra SATA ports on the motherboard (or
more accurately, not disabling them as the BIOS emulation appears
to...).

I've tried both a USB stick of 10.1 and an SSD with -CURRENT.  Both
use EFI booting and work on my Minnowboard.

Booting either way exhibits the same symptom.  /boot/loader.efi
runskoads the kernel and stuff but when it boots it prints

    Booting...
    Start @0xffffffff802e7000 ...
    _

(that's the address when booted from the SSD, the address for the 10.1
USB stick is 0xffffffff802df060)

and then hangs.

Thinking that maybe the console was pointing off somewhere, I tried
setting it at the forth/OK prompt, it was already set to "efi", which
seems like the best choice.

It'd be nice to get it booting via EFI.  Any suggestions for what to
try next?

Thanks,

g.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?21883.35789.822027.413019>