Skip site navigation (1)Skip section navigation (2)
Date:      Sat, 11 Aug 2007 09:31:34 -0700
From:      snowcrash+freebsd <schneecrash+freebsd@gmail.com>
To:        freebsd-ports@freebsd.org
Subject:   request add db45/db46 support to mail/exim port
Message-ID:  <70f41ba20708110931i4262c224kd0479290616c4fa8@mail.gmail.com>

Next in thread | Raw E-Mail | Index | Archive | Help
hi,

i've fbsd 62Rp7 installed.

i've updated my sys to use db46 (berkeley db), and set
WITH_BDB_VER/USE_BDB/etc accordingly in make.conf ...

current portupgrade complains:

 ** Port marked as IGNORE: mail/exim:
         is marked as broken: WITH_BDB_VER must be either 1, 4, 41, 42, 43 or 44

fix seems trivial,

------------------------------
diff -ur eximORIG/Makefile exim/Makefile
--- eximORIG/Makefile   Wed Aug  8 19:07:15 2007
+++ exim/Makefile       Wed Aug  8 19:10:30 2007
@@ -347,8 +347,12 @@
 DB_LIBS=       -L${LOCALBASE}/lib -ldb-4.4
 DB_INCLUDES=   -I${LOCALBASE}/include/db44
 LIB_DEPENDS+=  db-4.4.0:${PORTSDIR}/databases/db44
+.elif (${WITH_BDB_VER} == 45)
+DB_LIBS=    -L${LOCALBASE}/lib -ldb-4.5
+DB_INCLUDES=    -I${LOCALBASE}/include/db45
+LIB_DEPENDS+=   db-4.5.0:${PORTSDIR}/databases/db45
+.elif (${WITH_BDB_VER} == 46)
+DB_LIBS=    -L${LOCALBASE}/lib -ldb-4.6
+DB_INCLUDES=    -I${LOCALBASE}/include/db46
+LIB_DEPENDS+=   db-4.6.0:${PORTSDIR}/databases/db46
 .else
-BROKEN=                WITH_BDB_VER must be either 1, 4, 41, 42, 43 or 44
+BROKEN=                WITH_BDB_VER must be either 1, 4, 41, 42, 43,
44, 45 or 46
 .endif
 SEDLIST+=      -e 's,XX_DB_LIBS_XX,${DB_LIBS},' \
                -e 's,XX_DB_INCLUDES_XX,${DB_INCLUDES},'
------------------------------


thanks.



Want to link to this message? Use this URL: <http://docs.FreeBSD.org/cgi/mid.cgi?70f41ba20708110931i4262c224kd0479290616c4fa8>